본문 바로가기
조회 수 7424 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print

http://cafe.naver.com/neteg/64881


V. IP Multicast

 

IP 멀티캐스트는 하나 이상의 송신자(sender)가 제공하는 데이터를 특정한 하나 이상의 수신자들을 대상으로 스트림 형태의 데이터를 전송하는 방식이다. 일반적으로 유니캐스트 형태의 데이터 보다는 비디오(영상)와 보이스(전화)에서 사용되는 기술이다. 이는 특정한 소스를 그룹에 속한 여러 수신자들에게 스트림의 형태로 네트웍에 전달하는 용도로 사용된다. 또한 멀티캐스트는 라우팅 프로토콜등에서 네이버와의 정보 교환을 위해서도 사용되어진다. 멀티캐스트 관련 프로토콜은 아래 표처럼 크게 3가지로 카테고리로 구분된다.

 

[ - 멀티캐스트 프로토콜 분류]

구분

설명

IGMP

호스트와 라우터간에 멀티캐스트 정보를 교환하는 프로토콜이다. 종류로는 IGMP version1, IGMP version 2, IGMP version 3이 있다.

Multicast Routing Protocol<?xml:namespace prefix = o />

라우터와 라우터간에 멀티캐스트 정보를 교환하기 위한 라우팅 프로토콜이다. 여기에는 DVMRP, MOSPF, CBT, MBGP 그리고 PIM과 같은 라우팅 프로토콜들이 있다.

IGMP snooping

/ CGMP

라우터와 스위치간에 멀티캐스트 정보를 교환하는 프로토콜이다. 이는 멀티캐스트가 Layer 2 구간에서 브로드캐스트와 같이 동작하는 것을 방지하기 위한 기술이다. IGMP snooping은 표준기술, CGMP CISCO사가 개발한 독자적인 기술이다.

※ 참고로 CCIE R&S 시험에서는 거의 대부분 IGMP PIM만이 다루어진다.

 

일반적으로 멀티캐스트, 특히 PIM은 레이어 3계층 이상에서 동작하기 때문에 이를 운영하기 위해서는 네트웍에서 IP 라우팅이 먼저 구현되어 있어야 한다. 이런 사유로 CCIE R&S 시험에서 멀티캐스트에 선행하여 반드시 IGP BGP가 정상적으로 구현이 되어 있어야 한다. 결국 멀티캐스트는 이를 이용한 연장선상의 문제풀이 형태로 제공된다.

 

[멀티캐스트 문제 풀이 순서]

단계

항목

Step 1

PIM Sparse-Mode, Dense-Mode, Sparse-Dense-Mode 여부를 확인한다.

Step 2

PIM Sparse-Mode라면, Static-RP인지 Auto-RP인지 확인한다.

Step 3

RP별로 필터링이 사용되어야 하는지 확인한다.

Step 4

BSR(PIMv2)이나 MSDP가 필요한지도 확인한다.

Step 5

IGMP 필터링(IGMP profile)이 사용되어야 하는지 확인한다.

Step 6

기타 멀티캐스트 옵션(helper-map) 기능을 사용해야 하는지 확인한다.

 

사실 멀티캐스트는 상당히 광범위하고도 복잡한 기술이라 현실적으로 모든 이론을 경험하기에는 어려움이 있다. 그러나 CCIE R&S의 블루 프린트에서도 확인할 수 있듯이, 시험에서는 멀티캐스트 라우팅 프로토콜인 PIM RP, 그리고 호스트 통신을 위한 IGMP에 대해 주로 다루고 있고 이와 관련된 문제들이 대다수이다. 특히 시험은 IGMP와 뒤에 설명할 PIM 스파스 모드에 대한 연동 위주로 출제되니 이 부분에 집중하도록 하자. 그 외에도 MSDP SSM, 그리고 멀티캐스트 필터링 정도도 비교적 잘 출제니 확실히 이해하도록 한다.

 

[표 – IP Multicast 출제 범위]

IP Multicast

PIM-SM, bi-directional PIM, DVMRP

MSDP & Anycast

Multicast tools, source specific multicast

 

 

 

1. 개요

 

1) 유니캐스트와 멀티캐스트 비교

 

TCP/IP에서의 전송방식은 일반적으로 유니캐스트(unicast), 브로드캐스트(broadcast), 멀티캐스트(multicast)로 분류할 수 있다. 유니캐스트는 서버와 같은 특정 소스에서 하나의 호스트만을 위해 데이터를 전달하는 <?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 />1:1 방식이다. 유니캐스트는 일반적으로 데이터 통신을 위해 사용되는데, 현재 구축된 인터넷나 인트라넷 등은 유니캐스트 전송을 위해 디자인된 대표적인 네트웍이다. 장점은 통신을 원하는 장비들간에만 데이터 전송이 이루어지는 장점이 있지만, 수신자가 많아지면 소스를 제공하는 서버, 경유되는 네트웍 장비, 회선 사용률 등이 호스트의 수만큼 부하가 걸리게 된다.

 

브로드캐스트는 일반적으로 특정 소스에서 해당 네트웍, 정확히 말하자면 동일한 서브넷에 포함된 모든 호스트들에게 동일한 데이터를 송출하는 방식이다. 이는 1:ALL 방식인데, 장점으로는 호스트의 수에 관계없이 소스를 제공하는 서버는 하나의 데이터 또는 스트림을 발송만 하면 되고, 경유되는 네트웍 장비나 회선의 추가 부하가 없다는 것이다. 그러나 동일 서브넷에 포함된 호스트는 데이터의 수신을 원하지 않더라도 무조건 수신하게 되는 단점이 있다. 또한 브로드캐스트는 동일 서브넷, 즉 동일한 브로드캐스트 도메인에만 데이터를 전달하므로 L3 장비인 라우터와 MLS를 경유할 수 없는 단점이 있다. 이는 라우터의 ‘helper-address’를 활용함으로써 어느 정도 해결할 수는 있지만 궁극적으로는 대안이라고 볼 수 없다.

 

멀티캐스트는 유니캐스트와 브로드캐스트의 장점만을 취합하여 제안된 기술이다. 호스트가 스트림을 소스를 가진 서버에 조인(join)하기를 요청하면, 서버는 그 스트림을 그룹의 형태로 송출하게 된다. , 서버는 호스트의 수에 관계없이 특정 그룹을 목적지로 한 개의 스트림만을 전송하게 된다. 호스트가 그 멀티캐스트 그룹(group) IGMP를 이용하여 조인(join)신청을 하면 스트림을 수신하게 되고, 더 이상 수신하기를 원치 않으면 리브(leave)하면 된다. 이런 원리를 통해 호스트의 수에 관계없이 서버와 네트웍 장비들은 단일 스트림만을 전송하면 되고, 멀티캐스트 그룹에 소속된 호스트들만 스트림을 복사(copy)하여 수신하게 되는 것이다.

 

[그림 유니캐스트 vs 멀티캐스트

※ 출처 : BSCI

 

멀티캐스트를 단순하게 표현한다면 라우터를 지나갈 수 있는 브로드캐스트 스트림이라고도 할 수 있다. 사실 멀티캐스트도 몇가지 제약을 내포하고 있는데, 첫번째로 멀티캐스트를 운영하거나 경로를 계산하기 위해서 라우터들은 멀티캐스트 경로에 대한 라우팅 기능을 가지고 있어야 한다. 이런 사유로 멀티캐스트 네트워크의 라우터들은 PIM 같은 멀티캐스트 라우팅 프로토콜을 지원해야 한다. 참고로 멀티캐스트 라우팅 프로토콜에는 PIM 이외에도 DVMRP, MOSPF 그리고 MPBGP 같은 다양한 프로토콜이 있다.

 

두번째로 멀티캐스트가 레이어 3 기술이므로, 라우터와 호스트간에 스위치 같은 레이어 1이나 레이어 2 장비가 존재한다면 그 구간에서는 브로드캐스트처럼 동작해 버릴 수 있다. 왜냐하면 허브 또는 스위치는 멀티캐스트 같은 레이어 2 장비들은 레이어 3 데이터인 멀티캐스트를 바이패스하기 때문이다. 결국 멀티캐스트 그룹에 조인한 호스트 이외에도 동일한 서브넷에 존재하는 상관없는 호스트들에게까지 브로드캐스트처럼 멀티캐스트 스트림이 전달되어 버린다. 이를 해결하기 위한 기술도 존재하는데, 이는 ‘IGMP snooping’과 시스코사 제품에서만 제공되는 ‘CGMP’ 기능이 있다.

 

세번째로 멀티캐스트 트래픽에 대한 QoS를 정의할 수 없다는 이슈가 있다. 현재 멀트캐스트 트래픽은 모두 ‘Best Effort’로 처리된다. Best Effort란 네트워크 트래픽 혼잡(congestion)이 발생하더라도 QoS를 통한 우선순위(priority)를 적용하지 않은 상태를 의미한다. 이런 사유로 결국 멀티캐스트 트래픽에 대한 QoS를 설정할 수가 없다는 의미이다.


2) 멀티캐스트 어드레스

 

멀티캐스트에서 사용 가능한 어드레스는 ‘224.0.0.0’ 부터 ‘239.255.255.255’ 까지 이다. 기억해야 할 점은 멀티캐스트 어드레스도 IETF에 의해 영역별로 사용 용도가 정해져 있다는 것이다. 또한 중요한 것은 서브넷 마스크와 함께 할당되는 IP와는 달리 멀티캐스트는 단순한 호스트 IP 단위로만 할당이 되고 관리되어 진다는 것이다. 예를들어 OSPF에서 사용하는 멀티캐스트 IP로는 224.0.0.5가 할당되어 있는데, 이에 대한 별도의 서브넷 정보는 제공되지 않는다.

 

[멀티캐스트 어드레스 레인지]

범위

용도

설명

224.0.0.0 ~ 224.0.0.255

Reserved link local address

라우팅 프로토콜

224.0.1.0 ~ 238.255.255.255

Global range

인터넷

232.0.0.0 ~ 232.255.255.255

Source specific multicast

SSM

233.0.0.0 ~ 233.255.255.255

GLOP address

AS에 배정

239.0.0.0 ~ 239.255.255.255

Limited (local) scope

사설 IP 멀티캐스트

 

어플리케이션이 아닌 멀티캐스트 라우팅 프로토콜을 위해서도 일부 멀티캐스트 IP가 예약되어 있다. 일반적으로 224.0.0.0/24 클래스 이내에서 정의가 되어지며 자세한 내용은 아래 표와 같다.

 

[멀티캐스트 라우팅 프로토콜 어드레스]

구분

용도

224.0.0.1

서브넷의 모든 멀티캐스트 시스템

224.0.0.2

서브넷의 모든 라우터

224.0.0.4

DVMRP 라우터

224.0.0.5

OSPF 라우터

224.0.0.6

OSPF DR 라우터

224.0.0.9

RIP version 2 라우터

224.0.0.10

EIGRP 라우터

224.0.0.13

PIMv2 라우터

 

 

 

2. PIM-SM, bi-directional PIM (DVMRP 포함)

 

1) IGMP

 

앞서 설명하였듯이 네트웍 통신에서는 호스트가 사용하는 라우티드(routed) 프로토콜과 라우터간에 사용하는 라우팅 프로토콜(routing protocol)이 존재한다. 라우티드 프로토콜에는 IP, IPX, Appletalk등이 있고, 라우팅 프로토콜에는 RIP, OSPF, EIGRP, BGP등이 존재한다.

 

IP 멀티캐스트도 마찬가지로 주로 호스트가 사용하는 호스트용 프로토콜와 라우터와 라우터간에 경로계산을 위한 라우팅 프로토콜이 존재한다. 라우터와 호스트 구간에 사용되는 프로토콜로는 사실상 IGMP가 유일한데, IGMP‘Internet Group Management Protocol’의 약자로 버전 1, 버전 2 그리고 버전 3이 존재한다. IP 멀티캐스트 라우팅 프로토콜은 멀티캐스트 경로 계산 및 스트림 전달을 담당하는데, 대표적인 표준 프로토콜로는 DVMRP, MOSPF, CBT, MBGP등이 존재하지만 주로 PIM을 사용한다. PIM‘Protocol Independent Multicast’의 약자이며 명칭 그대로 다른 프로토콜에 관계없이 독립적으로 동작하는 장점이 있다.

 

[그림 영역별 멀티캐스트 기술]

 

CCIE R&S에서는 대부분 IGMP PIM만을 사용하여 멀티캐스트 환경을 구축한다. 여기서는 먼저 IGMP에 대해서 알아보자. IGMP는 일반적으로 멀티캐스트를 수신하려 하는 호스트와 이를 위한 라우터간에 사용하는 프로토콜이다. 호스트가 자신이 수신하려 하는 멀티캐스트 그룹 주소를 라우터에 등록하면 라우터는 이 주소를 참조하여 서버에게 멀티캐스트 스트림을 요청하게 된다. 라우터는 IGMP를 이용하여 10초 단위로 멀티캐스트 그룹에 아직 조인되어 있는 호스트가 있는지 질의(query)를 보내고, 지속적으로 멀티캐스트 스트림을 수신하기를 원하는 호스트가 한대라도 있다면, 한 호스트가 서브넷을 대표하여 반드시 10초 이내에 이에 대한 답변을 보내야 한다.

 

호스트가 멀티캐스트 그룹을 떠나기를 원한다면 어떻게 해야 할까? 라우터가 호스트에게 멀티캐스트 스트림을 지속적으로 수신을 원하는지에 대한 질의(query)를 보낼 경우 이에 대해 무시하거나 거부 의사를 밝히면 된다. IGMP 버전 1을 사용하는 호스트들은 멀티캐스트 그룹을 떠나기를 원할 때 보고없이 그냥 떠나 버린다. 라우터로부터 향후에도 지속적인 수신을 원하는지에 대한 질의(query) 1분 단위로 최대 3번까지 보내는데, 아무런 답변이 없을 경우에 더 이상의 멀티캐스트 호스트가 없다고 간주하고 서비스를 중단한다. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

 

IGMP 버전 1의 경우에는 멀티캐스트 수신 호스트가 없음에도 불구하고 익시파이어 타이머가(expire timer) 만료되는 최대 3분 동안에 불필요하게 멀티캐스트 스트림을 서브넷에 계속 보내게 된다는 단점이 있다. 이를 해결한 것이 IGMP 버전 2이다. IGMP 버전 2에서는 서브넷에서 멀티캐스트 그룹을 마지막으로 떠나는 호스트는 반드시 라우터에게 리브(leave) 메시지를 전달하여 더 이상의 멀티캐스트 수신을 원하는 호스트가 없음을 알리게 되어있다. IGMP 버전 3에서는 SSM(Source Specific Multicast) 기능이 제공된다.

 

CCIE R&S 시험에서는 호스트가 제공되지 않으므로 호스트를 대신하여 라우터의 인터페이스에 직접 IGMP 조인을 하게 설정한다.

 

[– IGMP 설정]

구분

명령어

IGMP

interface fastethernet 0/0

 ip igmp join-group ip-address

 

 


2) PIM

 

브로드캐스트는 1:N 통신이 가능하지만 레이어 3 장비인 라우터를 건너갈 수 없다. 유니캐스트는 라우팅 프로토콜을 통하여 라우터를 건너갈 수는 있지만 1:1 통신만이 가능하다. 이런 브로드캐스트와 유니캐스트의 장점을 합한 것이 멀티캐스트이다. 멀티캐스트 데이터(일반적으로 스트림이라고 표현한다)가 라우터를 건너다니기 위해서는 라우터간에 멀티캐스트들에 대한 경로를 알고 있어야 한다. 결국 일반 라우팅 프로토콜처럼 멀티캐스트도 경로를 알기 위한 멀티캐스트 라우팅 프로토콜이 존재한다.

 

라우터에서 멀티캐스트 라우팅 프로토콜을 사용하려면 아래처럼 멀티캐스트 라우팅 기능을 활성화 시켜 주어야 한다.

 

[멀티캐스트 라우팅 활성화 설정]

conf t

ip multicast-routing

 

 

 

그럼 이제부터 PIM 설정과 관련하여 RPF 계산 방식, PIM 모드, RP 설정등의 세가지 중요한내용에 대해 알아보도록 하자.

 

Sourse Distribution Tree vs Shared Distribution Tree

 

RPF(Reverse Path Forwarding)는 수신된 패킷이 최적의 경로를 통해 수신되었는지를 확인하여 전송 경로를 선택하는 것이다. 이를 위해 패킷이 라우터에 수신되고, 이를 수신한 라우터가 그 패킷이 유입된 인터페이스를 소스 중 하나의 최단 경로라고 판단되면, 라우터는 소스가 들어온 인터페이스를 제외한 나머지 모든 인터페이스로 그 패킷을 송출한다.

 

참고로 멀티캐스트 트래픽은 유니캐스트와 달리 데스티네이션 어드레스를 향해 전달되는 것이 아니라, 그룹 주소를 목적지로 하여 브로드캐스트 하는 것처럼 동작하기 때문에 전달 범위를 제한할 필요가 있다. 멀티캐스트 트래픽의 전달 범위, 즉 홉(hop)을 제한하기 위해 기본적으로 IP 헤더의 TTL 필드를 사용한다.

 

RPF를 생성하기 위해서는 소스 디스트리뷰션 트리(Source Distribution Tree)와 셰어드 디스트리뷰션 트리(Shared Distribution Tree)의 두가지 방법이 있다. 소스 디스트리뷰션 트리는 멀티캐스트 그룹에 속하는 수신 단말기들이 밀집된 형태에 적합하도록 설계되었다. 유니캐스트 라우팅 테이블을 기준한 최단 경로(SPF; Shortest Path First) 방식을 사용한다. SPF Outgoing Interface List가 있는 (S, G)엔트리로 관리되는데 이는 소스 콤마 지라고 읽히며 ‘S’는 소스 IP 어드레스, ‘G’는 멀티캐스트 그룹 IP 어드레스를 의미한다. 일반적으로 PIM Dense-Mode, DVMRP, MOSPF가 여기에 해당된다.

 

셰어드 디스트리뷰션 트리는 RP(Rendezvous Point)라고 하는 중앙 라우터를 셰어드 트리의 루트로 사용하는 분산환경에 적합한 트리 구조이다. 모든 소스 단말기는 자신의 멀티캐스트 트래픽을 RP로 보내고, RP는 다시 셰어드 디스트리뷰션 트리를 통해 모든 멀티캐스트 그룹에 속한 호스트들에게 스트림을 전달한다. 일반적으로 멀티캐스트 라우팅 테이블에서는 (*, G) 형태로 나타나는데 이는 스타 콤마 지라고 읽히며 ‘*’ all, G는 그룹 IP 어드레스를 의미한다. 소스 디스트리뷰션 트리는 송신 단말기의 수만큼 트리가 커지는데, 셰어드 디스트리뷰션 트리는 멀티캐스트 라우팅 트리의 수에 큰 영향을 주지 않는다. 여기에는 PIM Sparse-Mode가 해당된다.

 

[멀티캐스트 라우팅 프로토콜]

구분

Tree 방식

설명

종류

IGP

Source Distribution Tree

각 소스마다 root/tree가 존재

PIM-DM, DVMRP, MOSPF

Shared Distribution Tree

하나의 root/tree를 공유

PIM-SM, CBT

EGP

-

AS간에 사용

MBGP, MSDP

 

 

 

PIM Dense-Mode vs PIM Sparse-Mode

 

멀티캐스트 라우팅 프로토콜에는 Distance Vector 방식인 DVMRP(Distance Vector Multicast Routing Protocol), Link State 방식인 MOSPF(Multiprotocol OSPF), EGP에서 사용되는 MBGP(Multiprotocol BGP)등의 다양한 프로토콜이 존재한다. 그러나 CCIE R&S 시험을 포함하여 실제망에서는 대부분 PIM(Protocol-Indepedent Multicast)을 사용한다. PIM은 타  프로토콜로부터 독립적으로 동작할 수 있는 장점이 있기 때문이다.

 

PIM에는 앞서 설명하였듯이 덴스 모드(Dense-Mode)와 스파스 모드(Sparse-Mode)가 존재한다. PIM 덴스 모드는 랜과 같이 대역폭이 충분하고 비교적 범위가 작은 네트워크에 밀집되어 있는 환경에 적합하다. 소스 트리를 통해 멀티캐스트 트래픽을 전달하기 때문에 송신 단말기의 수만큼 트리를 가진다. RPF 알고리즘을 통해 ‘flooding’‘prune’ 작업을 진행하여 소스 트리를 구성한다. 이런 사유로 별도의 RP를 필요로 하지 않는다.

 

PIM 스파스 모드는 유니캐스트 라우팅 프로토콜과 함께 동작하여 멀티캐스트 스트림을 멀티캐스트 그룹으로 라우트하는 멀티캐스트 라우팅 프로토콜이다. 인터넷과 같은 광범위한 네트워크에 적합하며, 셰어드 트리와 소스 트리를 모두 지원하므로 반드시 RP가 존재하여야 한다. PIM에 대한 join 메시지가 있는 경우에만 해당 라우터로 포워딩하는 ‘pull’ 방식을 사용한다. 이런 사유로 PIM 스파스 모드는 양방향(bi-directional) 모드라고 불리운다.

 

[– PIM 구분]

구분

방식

RP 형태

규모

BSR

Sparse

Pull

Static RP

Auto RP

인터넷

PIM v2 지원

Dense

Prune

N/A

소규모 랜

미지원

 

시스코 라우터는 PIM 스파스 모드와 덴스 모드를 모두 지원하며, 추가적으로 스파스-덴스모드도 지원한다. PIM은 라우터의 해당 인터페이스에서 설정하면 되는데, 스파스-덴스 모드로 설정한다면 일반적으로 스파스 모드로 동작하게 되고, 스파스 모드에 문제가 있거나 멀티캐스트 그룹을 찾을 수 없다면 덴스 모드로 동작하게 된다.

 

참고로 PIM IP 위에서 동작하므로 PIM이 설정된 인터페이스는 반드시 IP를 가진 레이어 3 인터페이스여야만 한다. 만약에 물리적인 인터페이스가 아닌 서브 인터페이스 또는 인터페이스 VLAN IP를 가지고 있다고 가정하자. 이때는 물리적 인터페이스가 아닌, IP를 가진 서브 인터페이스 또는 인터페이스 VLAN PIM을 설정해야만 한다.

 

[– PIM 설정]

구분

명령어

Sparse-Mode

interface fastethernet 0/0

 ip pim sparse-mode

Dense-Mode

interface fastethernet 0/0

 ip pim dense-mode

Sparse-Dense-Mode

interface fastethernet 0/0

 ip pim sparse-dense-mode

 

CCIE R&S 시험에서는 사실상 PIM 스파스 모드 위주로 출제된다. 사유는 PIM 스파스 모드가 사실상 업계 표준이고, 또한 덴스보다 설정이나 구동이 복잡하기 때문에 시험용으로 적합하기 때문이다. PIM 덴스 모드는 독자적으로 시험에 출제되기 보다는 sparse-dense 모드가 복합된 형태로 출제된다.

 

[– Sparse-Mode vs Dense-Mode 라우팅 테이블 비교]

구분

명령어

설명

Sparse-Mode

(*, 224.1.1.1), 00:14:10/stopped, RP 1.1.1.1, flags: SJCLF

  Incoming interface: Serial1/0, RPF nbr 1.1.123.1

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse-Dense, 00:13:26/00:02:38

RP가 존재함

RPF 네이버 존재

 

Dense-Mode

(*, 224.2.2.2), 00:01:50/stopped, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Serial1/0, Forward/Sparse-Dense, 00:01:50/00:00:00

    FastEthernet0/1, Forward/Sparse-Dense, 00:01:50/00:00:00

    FastEthernet0/0, Forward/Sparse-Dense, 00:01:50/00:00:00

RP가 없음

RPF 네이버가 Null

 

 

 

Auto RP vs Static RP vs BSR

 

앞서도 설명했지만 RP는 랑데뷰 포인트를 의미하며 PIM 스파스 모드에서만 필요한 설정이다. RP는 멀티캐스트 소스와 리시버인 호스트가 만나는 라우터로서 관리자에 의해 명령어 설정만으로 역할이 결정된다. 오토 RP(Auto RP) RP로 지정된 라우터가 자신이 RP임을 네트웍상에 광고하는 방식이다. 이때는 RP를 제외한 다른 라우터에서는 RP와 관련하여 별도의 설정을 해줄 필요는 없다. 스태틱 RP(Static RP)의 경우에는 이 반대인데, RP로 결정된 라우터에서는 아무런 설정을 해줄 필요가 없지만 RP 이외의 라우터에서는 일일이 RP IP 주소를 등록해 주어야 한다.

 

오토 RP를 설정할 경우에는 ‘scope’ 명령어를 사용하여 TTL 값을 지정해 줄 수 있다. TTL은 최대로 멀티캐스트 라우팅을 지원하는 거리를 의미하는데, 일반적으로 16(hop) 정도로 지정하면 된다. 오토 RP와 스태틱 RP는 모두 적용시에 엑세스 리스트를 사용하여 조인 그룹(join-group)에 대해 필터를 설정할 수도 있다.

 

BSR(Bootstrap Router)은 여러 개의 RP 후보(candidate)들 중에서 RP를 선출하는 프로토콜로 PIM version 2에서 지원되는 기능이다. 이는 오토 RP와 유사한 기능을 제공하지만, 덴스 모드에 의존하지 않고 RP의 정보를 유니캐스트로 DR들에게 전달하는 기능이다. 참고로 멀티캐스트 그룹에 대한 조인이 정상적으로 동작하는지는 해당 IGMP 그룹 주소로의 ‘ping’ 테스트로 가능하다.

 

[– RP 설정]

구분

설정위치

명령어

Auto RP

RP

ip pim send-rp-announce loopback 0 scope 16 group-list 1

ip pim send-rp-discovery loopback 0 scope 16

!

access-list 1 permit 224.1.1.1

DR

N/A

Static RP

RP

N/A

DR

ip pim rp-address 1.1.1.1 1

!

access-list 1 permit 224.1.1.1

BSR

RP candidate

ip pim rp-candidate loopback 0 scope 16 group-list 1

!

access-list 1 permit 224.1.1.1

BSR

Ip pim bsr-candidate loopback 0

DR

N/A

※ 위는 RP 주소가 1.1.1.1이고 join-group 224.1.1.1만 허용하는 경우의 샘플이다.

 

멀티캐스트 정보를 전달하는 용도로는 IANA에서 정의된 두개의 멀티캐스트 그룹 어드레스가 있다. 참고로 DR Designated Router의 약자로 멀티캐스팅이 가능한 호스트를 가진 일반 라우터를 의미한다.

 

[멀티캐스트 정보 전달 어드레스]

구분

어드레스

설명

Cisco-Announce

224.0.1.39

RP 후보자(candidate) BSR 같은 RP 맵핑 애이전트(Mapping Agent)들에게 자신이 RP가 되기를 원하는 그룹의 주소를 알리는 용도로 사용된다.

Cisco-Discovery

224.0.1.40

RP 후보자(candidate)로부터 수신한 그룹 정보를 RP 맵핑 애이전트(Mapping Agent)가 수집하여 DR들에게 알리는 용도로 사용된다.

※ 멀티캐스트가 동작중인 시스코 라우터에서 ‘show ip mroute’를 실행하면 기본적으로 ‘224.0.1.40’에 대한 멀티캐스트 라우팅 테이블을 볼 수 있다.

 

 

 

끝으로 DVMRP는 인터넷과 시험장 모두에서 사실상 사용되어지지 않으므로 여기서 간단히설명하고 넘어가기로 하자. DVMRP(Distance-Vector Multicast Routing Protocol) RPF 기술을 사용하고 인터넷의 MBONE(Multicast Backbone)에 대한 기본 프로토콜로 사용되며 RFC 1075에 정의되어 있다. 몇 가지 단점이 있는데, DVMRP의 라우트 방법은 ‘broadcast & prune’으로 요약 될 수 있는데, 특히 프루닝(pruning)이 구현되지 않은 버전에서 리플러딩(reflooding)으로 인해 네트워크 확장 문제가 있다.

 

  


[출제유형 1 – PIM Sparse-Mode 설정]

구분

내용

토폴로지

출제유형

아래 인터페이스에 IP Multicast 라우팅을 활성화 시켜라.

- R1 : S0. Lo0

- R2 : S0, Lo0

- R3 : S0, F0/0, F0/1

R3 F0/0에는 224.1.1.1, F0/1에는 224.2.2.2가 조인되어야 한다. 224.1.1.1만에 대해서는 R1 loopback0 RP가 되어야 하며 224.2.2.2만에 대해서는 R2 loopback0 RP가 되어야 한다. 이때 R3에서 RP를 설정할 수는 없으며, 덴스 모드도 사용할 수 없다. 설정 완료후 224.1.1.1 224.2.2.2 ping 테스트시 성공하여야 한다. (IP IGP는 미리 설정되어 있으며 R3 hub이다.)

설명

정리해보면 아래와 같다.

- PIM 모드 : 스파스 모드 (sparse mode)

- RP : Auto-RP

- IGMP Join Group : R3 F0/0 (224.1.1.1), R3 F0/1(224.2.2.2)

솔루션

[R1]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip pim sparse-mode

!

interface Serial1/0

 ip address 1.1.123.1 255.255.255.248

 ip pim sparse-mode

!

ip pim send-rp-announce Loopback0 scope 16 group-list 1

ip pim send-rp-discovery Loopback0 scope 16

!

access-list 1 permit 224.1.1.1

 

[R2]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.2.2 255.255.255.255

 ip pim sparse-mode

!

interface Serial1/0

 ip address 1.1.123.2 255.255.255.248

 ip pim sparse-mode

!

ip pim send-rp-announce Loopback0 scope 16 group-list 2

ip pim send-rp-discovery Loopback0 scope 16

!

access-list 2 permit 224.2.2.2

 

[R3]

ip multicast-routing

!

interface Serial1/0

 ip address 1.1.123.3 255.255.255.248

 ip pim sparse-mode

!

interface FastEthernet0/0

 ip address 1.1.30.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.1.1.1

!

interface FastEthernet0/1

ip address 1.1.31.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.2.2.2

결과값

[R3]

R3#show ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

      S - State Refresh Capable

Neighbor          Interface                Uptime/Expires    Ver   DR

Address                                                            Prio/Mode

1.1.31.3          FastEthernet0/0          00:07:17/00:01:21 v2    1 / DR S

1.1.30.3          FastEthernet0/1          00:07:17/00:01:20 v2    1 / S

1.1.123.2         Serial1/0                00:06:04/00:01:33 v2    1 / S

1.1.123.1         Serial1/0                00:06:05/00:01:34 v2    1 / S

 

R3#show ip pim rp mapping

PIM Group-to-RP Mappings

 

Group(s) 224.1.1.1/32

  RP 1.1.1.1 (?), v2v1

    Info source: 1.1.1.1 (?), elected via Auto-RP

         Uptime: 00:01:13, expires: 00:02:42

Group(s) 224.2.2.2/32

  RP 1.1.2.2 (?), v2v1

    Info source: 1.1.2.2 (?), elected via Auto-RP

         Uptime: 00:01:06, expires: 00:02:52

 

R3#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 224.2.2.2), 00:08:29/00:02:19, RP 1.1.2.2, flags: SJCL

  Incoming interface: Serial1/0, RPF nbr 1.1.123.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:08:29/00:02:19

 

(*, 224.1.1.1), 00:08:29/00:02:13, RP 1.1.1.1, flags: SJCL

  Incoming interface: Serial1/0, RPF nbr 1.1.123.1

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:07:45/00:02:13

(이하 생략)

 

 


[출제유형 2 – PIM Sparse-Dense-Mode 설정]

구분

내용

토폴로지

출제유형

아래 인터페이스에 IP Multicast 라우팅을 활성화 시켜라.

- R1 : S0. Lo0

- R2 : S0, Lo0

- R3 : S0, Lo0, F0/0, F0/1

R3 F0/0에는 224.1.1.1, F0/1에는 224.2.2.2가 조인되어야 한다. R1 loopback0224.1.1.1만에 대해서만 RP가 되어야 한다. 이때 RP는 반드시 R3에서만 설정해야 한다. 나머지 IGMP 그룹에 대해서도 정상적으로 통신이 되어야 한다. (IP IGP는 미리 설정되어 있으며 R3 hub이다.)

설명

정리해보면 아래와 같다.

- PIM 모드 : sparse-dense-mode (224.1.1.1에 대해서만 R1 sparse-mode에서 RP로 동작, 나머지 멀티캐스트 IP dense-mode로 동작함)

- RP : Static-RP (R3에서 224.1.1.1에 대해 R1RP로 스태틱하게 등록)

- IGMP Join Group : R3 F0/0 (224.1.1.1), R3 F0/1(224.2.2.2)

※ 주의 : 224.1.1.1 RP가 있으므로 sparse-mode로 동작하고, 224.2.2.2 RP가 없으므로 dense-mode로 동작한다.

솔루션

[R1]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip pim sparse-dense-mode

!

interface Serial1/0

 ip address 1.1.123.1 255.255.255.248

ip pim sparse-dense-mode

 

[R2]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.2.2 255.255.255.255

ip pim sparse-dense-mode

!

interface Serial1/0

 ip address 1.1.123.2 255.255.255.248

ip pim sparse-dense-mode

 

[R3]

ip multicast-routing

!

interface Serial1/0

 ip address 1.1.123.3 255.255.255.248

ip pim sparse-dense-mode

!

interface FastEthernet0/0

 ip address 1.1.30.3 255.255.255.0

ip pim sparse-dense-mode

 ip igmp join-group 224.1.1.1

!

interface FastEthernet0/1

ip address 1.1.31.3 255.255.255.0

ip pim sparse-dense-mode

 ip igmp join-group 224.2.2.2

!

ip pim rp-address 1.1.1.1 1

!

access-list 1 permit 224.1.1.1

결과값

[R3]

R3#show ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

      S - State Refresh Capable

Neighbor          Interface                Uptime/Expires    Ver   DR

Address                                                            Prio/Mode

1.1.31.3          FastEthernet0/0          00:13:32/00:01:29 v2    1 / DR S

1.1.30.3          FastEthernet0/1          00:13:32/00:01:30 v2    1 / S

1.1.123.2         Serial1/0                00:12:20/00:01:41 v2    1 / S

1.1.123.1         Serial1/0                00:12:20/00:01:42 v2    1 / S

 

R3#show ip pim rp mapping

PIM Group-to-RP Mappings

 

Acl: 1, Static

    RP: 1.1.1.1 (?)

 

R3#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 224.2.2.2), 00:01:50/stopped, RP 0.0.0.0, flags: DCL

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    Serial1/0, Forward/Sparse-Dense, 00:01:50/00:00:00

    FastEthernet0/1, Forward/Sparse-Dense, 00:01:50/00:00:00

    FastEthernet0/0, Forward/Sparse-Dense, 00:01:50/00:00:00

 

(*, 224.1.1.1), 00:14:10/stopped, RP 1.1.1.1, flags: SJCLF

  Incoming interface: Serial1/0, RPF nbr 1.1.123.1

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse-Dense, 00:13:26/00:02:38

(이하 생략)

 

 


[출제유형 3 – PIM BSR 설정]

구분

내용

토폴로지

출제유형

아래 인터페이스에 IP Multicast 라우팅을 활성화 시켜라.

- R1 : S0. Lo0

- R2 : S0, Lo0

- R3 : S0, Lo0, F0/0, F0/1

R3 F0/0에는 224.1.1.1, F0/1에는 224.2.2.2가 조인되어야 한다. R1 loopback0 R2 loopback0 RP로 선정될 수 있다. 이때 R3에는 PIM version 2를 설정하여 R1 R2중에 RP를 결정해야 한다. 설정 완료후 224.1.1.1 224.2.2.2 ping 테스트시 성공하여야 한다. (IP IGP는 미리 설정되어 있으며 R3 hub이다.)

설명

정리해보면 아래와 같다.

- PIM 모드 : 스파스 모드 (sparse mode)

- RP : R1 R2 RP 후보자로 설정하고, R3 BSR 설정을 하라는 의미임.

- IGMP Join Group : R3 F0/0 (224.1.1.1), R3 F0/1(224.2.2.2)

NBMA 환경에서 BSR hub 라우터가 되어야 한다.

솔루션

[R1]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip pim sparse-mode

!

interface Serial1/0

 ip address 1.1.123.1 255.255.255.248

 ip pim sparse-mode

!

ip pim rp-candidate Loopback0

 

[R2]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.2.2 255.255.255.255

 ip pim sparse-mode

!

interface Serial1/0

 ip address 1.1.123.2 255.255.255.248

 ip pim sparse-mode

!

ip pim rp-candidate Loopback0

 

[R3]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.3.3 255.255.255.255

 ip pim sparse-mode

!

interface Serial1/0

 ip address 1.1.123.3 255.255.255.248

 ip pim sparse-mode

!

interface FastEthernet0/0

 ip address 1.1.30.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.1.1.1

!

interface FastEthernet0/1

ip address 1.1.31.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.2.2.2

!

ip pim bsr-candidate Loopback0 0

결과값

[R3]

R3#show ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

      S - State Refresh Capable

Neighbor          Interface                Uptime/Expires    Ver   DR

Address                                                            Prio/Mode

1.1.31.3          FastEthernet0/0          00:18:41/00:01:43 v2    1 / DR S

1.1.30.3          FastEthernet0/1          00:18:41/00:01:16 v2    1 / S

1.1.123.2         Serial1/0                00:17:29/00:01:25 v2    1 / S

1.1.123.1         Serial1/0                00:17:29/00:01:28 v2    1 / S

 

R3#show ip pim rp mapping

PIM Group-to-RP Mappings

This system is the Bootstrap Router (v2)

 

Group(s) 224.0.0.0/4

  RP 1.1.2.2 (?), v2

    Info source: 1.1.123.2 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 00:01:25, expires: 00:02:03

  RP 1.1.1.1 (?), v2

    Info source: 1.1.123.1 (?), via bootstrap, priority 0, holdtime 150

         Uptime: 00:00:40, expires: 00:01:47

 

R3#show ip pim bsr-router

PIMv2 Bootstrap information

This system is the Bootstrap Router (BSR)

  BSR address: 1.1.3.3 (?)

  Uptime:      00:02:27, BSR Priority: 0, Hash mask length: 0

Next bootstrap message in 00:00:33

 

R3#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 224.2.2.2), 00:04:02/00:02:26, RP 1.1.2.2, flags: SJCL

  Incoming interface: Serial1/0, RPF nbr 1.1.123.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:04:02/00:02:26

 

(*, 224.1.1.1), 00:22:20/00:02:24, RP 1.1.2.2, flags: SJCLF

  Incoming interface: Serial1/0, RPF nbr 1.1.123.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:21:36/00:02:24

(이하 생략)

 

 

 

3. MSDP & Anycast RP

 

PIM Sparse-Mode로 설정된 네트워크는 RP와 관련된 몇가지 이슈가 있다. 첫번째 이슈는 RP가 다운된다면 멀티캐스트 통신이 불가능해 질 것이라는 것이다. 두번째 이슈는 RP로 집중되는 트래픽에 대한 로드 밸런싱이 불가능하다는 것이다. 이러한 RP 이중화와 로드 밸런싱 이슈를 해결하기 위해 애니캐스트 RP(Anycast RP)가 대두되었다.

 

애니캐스트는 원래 IPv6에서 지원하는 전송 방식으로 여러대의 장비가 동일한 IP 어드레스를 공유하는 방식이다. 만약 이 IP 어드레스로 서비스 요청이 들어오면 여러대의 서버중 한대가 서비스에 응답해 주는 방식이다.

 

MSDP(Multicast Source Discovery Protocol)는 이러한 애니캐스트의 방식을 멀티캐스트에 도입한 기술이다. MSDP를 구현하려면 RP가 되려는 두대의 라우터가 애니캐스트용으로 동일한 loopback 인터페이스의 IP를 사용하고 이를 라우팅 프로토콜로 공유하면 된다.

 

[– MSDP 설정]

구분

설정위치

명령어

MSDP

RP 1

ip msdp peer 1.1.2.2 connect-source loopback 0

ip msdp originator-id loopback 0

!

ip pim rp-address 192.168.255.254

RP 2

ip msdp peer 1.1.1.1 connect-source loopback 0

ip msdp originator-id loopback 0

!

ip pim rp-address 192.168.255.254

연동 장비

ip pim rp-address 192.168.255.254

※ 위는 RP 주소가 192.168.255.254이고 R1 R2의 대표 IP 1.1.1.1 1.1.2.2인 경우의 샘플임

 

 


[출제유형 1 – MSDP 설정]

구분

내용

토폴로지

출제유형

아래 인터페이스에 IP Multicast 라우팅을 활성화 시켜라.

- R1 : S0. Lo0

- R2 : S0, Lo0

- R3 : S0, F0/0, F0/1

R3 F0/0에는 224.1.1.1, F0/1에는 224.2.2.2가 조인되어야 한다. MSDP 기능을 이용하여 R1 R2에 각각 Lo192 192.168.255.254라는 IP를 입력하고 아무 라우팅 프로토콜을 사용하여 이를 공유해야 한다. R3 192.168.255.254 RP로 선정하여야 한다. 설정 완료후 224.1.1.1 224.2.2.2 ping 테스트시 성공하여야 한다. (IP IGP는 미리 설정되어 있으며 R3 hub이다.)

설명

정리해보면 아래와 같다.

- PIM 모드 : 스파스 모드 (sparse mode)

- RP : Anycast RP

- IGMP Join Group : R3 F0/0 (224.1.1.1), R3 F0/1(224.2.2.2)

솔루션

[R1]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip pim sparse-mode

!

interface Loopback192

 ip address 192.168.255.254 255.255.255.255

!

interface Serial1/0

 ip address 1.1.123.1 255.255.255.248

 ip pim sparse-mode

!

router ospf 1

 network 192.168.255.254 0.0.0.0 area 0

!

ip pim rp-address 192.168.255.254

ip msdp peer 1.1.2.2 connect-source Loopback0

ip msdp originator-id Loopback0

 

[R2]

ip multicast-routing

!

interface Loopback0

 ip address 1.1.2.2 255.255.255.255

 ip pim sparse-mode

!

interface Loopback192

 ip address 192.168.255.254 255.255.255.255

!

interface Serial1/0

 ip address 1.1.123.2 255.255.255.248

 ip pim sparse-mode

!

router ospf 1

network 192.168.255.254 0.0.0.0 area 0

!

ip pim rp-address 192.168.255.254

ip msdp peer 1.1.1.1 connect-source Loopback0

ip msdp originator-id Loopback0

 

[R3]

ip multicast-routing

!

interface Serial1/0

 ip address 1.1.123.3 255.255.255.248

 ip pim sparse-mode

!

interface FastEthernet0/0

 ip address 1.1.30.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.1.1.1

!

interface FastEthernet0/1

ip address 1.1.31.3 255.255.255.0

 ip pim sparse-mode

 ip igmp join-group 224.2.2.2

!

ip pim rp-address 192.168.255.254

결과값

[R1]

R1#show ip msdp summary

MSDP Peer Status Summary

Peer Address     AS    State    Uptime/  Reset SA    Peer Name

                                Downtime Count Count

1.1.2.2          ?     Up       00:04:28 0     0     ?

 

[R2]

R2#show ip msdp summary

MSDP Peer Status Summary

Peer Address     AS    State    Uptime/  Reset SA    Peer Name

                                Downtime Count Count

1.1.1.1          ?     Up       00:04:43 0     2     ?

 

[R3]

R3#show ip pim neighbor

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

      S - State Refresh Capable

Neighbor          Interface                Uptime/Expires    Ver   DR

Address                                                            Prio/Mode

1.1.31.3          FastEthernet0/0          00:05:33/00:01:36 v2    1 / DR S

1.1.30.3          FastEthernet0/1          00:05:33/00:01:34 v2    1 / S

1.1.123.2         Serial1/0                00:03:51/00:01:27 v2    1 / S

1.1.123.1         Serial1/0                00:04:50/00:01:20 v2    1 / S

 

R3#show ip pim rp mapping

PIM Group-to-RP Mappings

 

Group(s): 224.0.0.0/4, Static

    RP: 192.168.255.254 (?)

 

R3#show ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

 Timers: Uptime/Expires

 Interface state: Interface, Next-Hop or VCD, State/Mode

 

(*, 224.2.2.2), 00:06:42/stopped, RP 192.168.255.254, flags: SJCLF

  Incoming interface: Serial1/0, RPF nbr 1.1.123.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:06:42/00:02:57

 

(*, 224.1.1.1), 00:06:43/stopped, RP 192.168.255.254, flags: SJCLF

  Incoming interface: Serial1/0, RPF nbr 1.1.123.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:05:00/00:02:59

(이하 생략)

 

 


4. Multicast tools, Source Specfic Multicast

 

이번장에서는 멀티캐스트툴과 SSM에 대해 언급해 보기로 한다. 멀티캐스트툴은 IOS feature 처럼 멀티캐스트를 위한 옵션적인 기능들이다. 여기서는 간단하게 helper-map, IGMP profile, dm-fallback 모드에 대해서 학습해 보기로 한다. 그리고 SSM에 대해 간단히 알아보기로 하자.

 

 

 

1) Helper-map

 

멀티캐스트 헬퍼맵은 서버로부터 수신된 브로드캐스트 패킷을 멀티캐스팅이 가능한 네트워크를 통해 전달하여 호스트에게 전달하는 방법이다. 앞서 배운 헬퍼 어드레스(helper-address)와 유사한 개념으로 주로 UDP 브로드캐스트 패킷을 지정된 목적지 어드레스로 지정하고 전달한다. , ‘172.16.1.255 255.255.255.0’ 같은 브로드캐스트 패킷을 수신하여 ‘224.1.1.1’과 같은 멀티캐스트 라우팅이 가능한 어드레스로 변경하여 라우터를 넘나들게 하는 기술이다. 멀티캐스트로 변환된 브로드캐스트를 수신하기 원하는 호스트와 연동된 최종단 라우터에서는 다시 멀티캐스트를 브로드캐스트로 변환하여 전달하는 것도 가능하다.

 

[멀티캐스트 helper-map 설정]

구분

명령어

Broadcast

to Multicast

interface fastethernet 0/0

ip multicast helper-map broadcast group-address access-list

!

access-list 100 permit udp any any #

ip forward-protocol udp #

Multicast

to Broadcast

interface fastethernet 0/0

ip multicast helper-map group-address broadcast-address access-list

!

access-list 100 permit udp any any #

ip forward-protocol udp #

 

 

 

2) IGMP profile

 

IGPM profile Layer 2의 스위치 포트로부터 IGMP membership report들을 필터링하는 용도로 사용된다. 일반적으로 라우터의 이더넷 인터페이스에 적용하여 간단히 구현할 수 있다. 다만 현재의 다이나밉스에서 사용하는 IOS에서는 해당 기능이 지원되지 않는다. 설정 방법은 먼저 필터링하기 원하는 그룹에 대한 어드레스를 범위로 설정하는 IGMP profile을 만들고, 그후에 이를 인터페이스에 적용하면 된다.

 

[– IGMP filtering 설정]

구분

명령어

IGMP profile

ip igmp profile #

 permit

 range 239.0.0.0 239.255.255.255

!

interface fastethernet 0/0

ip igmp filter #

 

 

 

3) dm-fallback

 

멀티캐스트를 위해 PIM이 선언된 인터페이스가 sparse-dense-mode로 동작되어 있다면 라우터는 일차적으로 sparse 모드를 먼저 사용하고, 문제가 있을 경우 dense 모드로 동작한다. 이때 글로벌 모드에서 ‘no ip dm-fallback’ 명령어를 사용하면 인터페이스에서 sparse-dense-mode를 그대로 둔 상태에서도 dense-mode 기능을 비활성화 시킬 수 있다.

 

[– dm-fallback 설정]

구분

명령어

dm-fallback

conf t

no ip pim dm-fallback

 

 

 

4) SSM

 

SSM(Source-Specific Multicast) IETF RFC 3569에 제정된 표준이다. 이는 멀티캐스트 네트웍에서 라우터가 아닌 호스트에서 직접 소스 IP 주소인 (S)와 멀티캐스트 그룹 주소를 (G)를 수신하므로, 결국 채널 (S,G)를 통하여 멀티캐스트 데이터그램을 받을 수 있다. 이는 PIM Sparse-Mode와 유사하지만, 호스트가 직접 (S,G)를 수신하기 때문에 RP없이 구성할 수 있다는 장점이 있다.

 

그러나 (S,G)를 직접 수신하기 위해서는 호스트가 IGMP version 3를 지원해야 않다. 만약 호스트가 IGMP version 1,2만 지원한다면 추가로 URD 기능을 지원해야 한다. SSM IPv4 뿐만 아니라 IPv6에서도 사용할 수 있는데, 이때는 호스트가 그룹 조인 위해서 IGMP version 3 프로토콜 혹은 MLDv2 프로토콜이 필요하다.

 

[– SSM 설정]

구분

명령어

SSM

conf t

ip igmp ssm-map enable

ip igmp ssm-map access-list #

 

 

 

- V. IP Multicast 편 완료 -

 

 

[copy right by CrazyWoo(우명하); woomha@naver.com]


Title
List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 How To Install GNS3 on Ubuntu 10.04 LTS Hojung 2011.04.25 5579
50 Cisco SPAN Hojung 2013.04.17 1836
49 f/r setting on main interface Hojung 2011.05.03 1955
48 Reset configuration in router/switch Hojung 2011.05.03 2160
47 Basic Configuration (password, domain-lookup, hostname, timeout) Hojung 2011.05.03 2713
46 [Crazy4CCIE-R&S편]VII.Security Hojung 2011.04.27 4487
45 [Crazy4CCIE-R&S편]VI. IP QoS (완료) Hojung 2011.04.27 8067
» [Crazy4CCIE-R&S편]V.IP Multicast (완료) Hojung 2011.04.27 7424
43 [Crazy4CCIE R&S편]번외편 - 다이나밉스 운영 환경 최적화 Hojung 2011.04.27 4601
42 [Crazy4CCIE-R&S편]IV.IP and IOS Feature (완료) Hojung 2011.04.27 5693
41 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(3)-OSPFv3) Hojung 2011.04.27 4321
40 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(2)-RIPng) Hojung 2011.04.27 3042
39 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(1)-Concept) Hojung 2011.04.27 2915
38 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(3)-Red&Filter) Hojung 2011.04.27 2457
37 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(2)-Red&Metric) Hojung 2011.04.27 4516
36 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(1)-Concept) Hojung 2011.04.27 6312
35 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(3)-distribute-list-설정) Hojung 2011.04.27 3241
34 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(2)-labconfig) Hojung 2011.04.27 2179
33 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(1)-concept Hojung 2011.04.27 2032
32 [Crazy4CCIE-R&S편]II.IGP(6-Filtering-(1~5)access-list&prefix-list Hojung 2011.04.27 3434
31 [Crazy4CCIE-R&S편]II.IGP(5-EIGRP-(5)-Authentication) Hojung 2011.04.27 2456
Board Pagination ‹ Prev 1 2 3 Next ›
/ 3

Designed by sketchbooks.co.kr / sketchbook5 board skin

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5