본문 바로가기
조회 수 6348 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print

http://cafe.naver.com/neteg/62337


IV. IP and IOS Feature

 

시스코 라우터에서 IP 패킷의 포워딩을 담당하고 또한 다양한 기능들을 구현하기 위한 OS IOS(Internetworking Operating System)이다. 이는 시스코사 제품 또는 버전별로 다양한 기능을 가지고 있다. 현재 CCIE R&S에서 사용되는 라우터에서 사용되는 IOS‘12.4’이고 스위치를 위한 IOS‘12.2’이다. 라우터와 스위치는 그 H/W S/W에 따라 구현되는 기능이 다소 다르지만 명령어와 그 체계는 전체적으로 대동소이하다.

 

인터넷과 컴퓨팅 환경은 IP 통신을 하고 있으므로 라우터와 스위치(MLS) IP 패킷에 대한 포워딩을 그 첫번째 기능으로 하고 있다. 그렇지만 다양한 서비스의 증가와 인터넷 기술의 발달로 라우터와 MLS가 처리해야 할 일은 점점 더 많아지고 복잡해지고 있다. 결국 지금의 라우터와 스위치는 IP 패킷의 포워딩 뿐만 아니라 인터넷이 요구하는 수많은 부가 기능들을 수행할 필요가 있다. 이번 장에서는 시스코 IOS로 구현이 가능한 다양한 표준 또는 비표준의 기능들에 대해 학습해 보자.<?xml:namespace prefix = o /><?xml:namespace prefix = o />

 

[표 – IOS Feature 출제 범위]

IP and IOS Feature

IP addressing

DHCP

HSRP

IP services

IOS user interfaces

System management

NAT

NTP

SNMP (/w RMON)

Accounting

<?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 />SLA

※ 추가 : CORE-DUMP, Summer-time

 

 

 

1. IP addressing

 

1) Concept

 

IP 어드레싱은 상당히 광범위한 범주를 다루는 문구이다. 라우터나 스위치(MLS)가 레이어 3의 기능을 제공하기 위해 제작된 플랫폼이므로 IP와 관련된 제반 기능을 다루기 때문이다. 이런 의미에서 IP 어드레싱에 대한 개념을 확실히 알고 넘어가는 것이 중요하다.

 

일반적으로 IP 어드레스는 32bit로 구성되어지고 점(dot)로 구분되어지는 8bit의 필드를 4개 가진다. 이 점(dot)으로 구분되는 4개의 필드를 옥텟이라고 부른다. IP 어드레스는 사용의 효율성을 위해 클래스를 나누게 되는데, 일반적으로 A, B, C 클래스가있다. 클래스는 원래 해당 IP가 속한 그룹을 의미하는 네트웍 파트와, 자신의 고유 번호를 의미하는 호스트 파트로 구분된다. 물론 최근에는 IP를 더 효율적으로 사용하기 위해 서브넷, 서브넷 마스크, VLSM, CIDR등의 개념도 도입되어 사용되고 있다.

 

CCIE R&S 시험은 거의 대부분의 문제가 IP 어드레스를 기반으로 하기 때문에 정확한 IP 어드레스에 대한 정확한 이해가 필요하다. 여기서는 IP와 관련된 다양한 개념을 학습해 보도록 한다.

 

 

2) 동작 원리

 

IP는 인터넷 통신을 하기 위한 레이어3의 표준 프로토콜이다. 앞서 설명한대로 최대 256이라는 수가 점(dot)으로 구분된 4부분의 옥텟으로 분리되는 형태를 가지고 있다. 논리적으로 IP는 자신이 속한 그룹을 나타내는 네트웍 파트와 자신의 고유 어드레스를 의미하는 호스트 파트로 나뉘어 진다. 원칙적으로 IP는 자신이 속한 네트웍에 포함된 다른 호스트들과만 통신이 가능하다.

 

다른 네트웍과 통신을 하기 위해 가능하게 게이트웨이 역할을 해주는 장비가 바로 라우터이다. 여기서는 IP의 클래스, 서브넷, 서브넷 마스크, VLSM, CIDR등에 대해서 학습해 보자.

 

 

① 클래스풀(classful) VS 클래스리스(classless)

 

네트웍을 구축할 때 중요한 것은 네트웍이 얼마나 많은 수의 호스트를 가지게 될 것인가 하는것과 이러한 네트웍들의 수가 얼마나 존재하는가 하는 것이다. 이를 정확히 알아야만 필요한 IP의 수와 서브넷의 수를 책정할 수 있기 때문이다. 서브넷이란 동일 도메인 내에서 라우팅없이 통신이 가능한 논리적인 도메인이라는 의미이다. IP 네트웍은 최초에 이러한 서브넷의 개념을 도입하여 디자인 되었는데, 이가 바로 클래스풀(classful) 네트웍의 개념이다. 클래스풀 네트웍에서 서브넷의 크기는 크게 3개로 나뉘어 진다.

 

[ - 클래스풀(classful) 네트웍 구분]

구분

용도

서브넷의

가용 호스트 수

영역

A Class

인터넷

16,777,216

0.0.0.0~127.255.255.255

B Class

인터넷

65536

128.0.0.0~191.255.255.255

C Class

인터넷

256

192.0.0.0~223.255.255.255

D Class

멀티캐스트

-

224.0.0.0~239.255.255.255

E Class

R&D

-

240.0.0.0~255.255.255.255

 

클래스풀에서도 서브넷의 개념은 존재한다. 위의 표에서도 알 수 있듯이 IP의 첫옥텟의 수만 보면 그 클래스를 알 수 있으므로 통신시에 서브넷에 대한 정보를 전달하지 않는다. , ‘1.2.3.4’ 라는 IP가 있다면, 첫 옥텟인 ‘1’만 보고 A 클래스임을 짐잘할 수 있다. 뒤의 ‘2.3.4’는 호스트의 고유한 어드레스임을 의미한다.

 

참고로 A, B, C 클래스 영역에서는 IP의 재사용이 가능한 사설 IP가 정의되어 있다. 위의 IP 범위에서 각각 클래스별로 사설 IP들을 정의하고 IP를 할당해 주는 공인 기관인 IANA에서 이 네트웍에 대해서는 어떠한 기관에게도 공인 IP로 할당해 주지 않는다. 결국 사설 IP는 전세계의 어떤 기관에서도 마음대로 사용이 가능하지만, 인터넷으로 절대 광고가 되지도 않고, 설령 실수로 광고가 되더라도 ISP들에 의해 라우팅에서 필터링 처리하고 있다.

 

[사설IP 범위]

구분

IP 범위

서브넷 수

영역

A Class

10.0.0.0/8

A Class 1

10.0.0.0 ~ 10.255.255.255

B Class

172.16.0.0/12

B 클래스 16

172.16.0.0 ~ 172.31.255.255

C Class

192.168.0.0/16

C 클래스 256

192.168.0.0 ~ 192.168.255.255

Local Host

127.0.0.1

호스트 1

127.0.0.1

 

클래스풀 시스템은 치명적인 문제를 가지고 있다. 그것은 바로 IP의 비효율적인 할당이다. 클래스풀에서는 서브넷 정보를 전달하지 않기 때문에 무조건 A, B, C 클래스의 세가지 유형으로만 네트웍을 구분할 수 있다예를들어 호스트가 200개인 네트웍을 위해서는 C클래스인 ‘192.168.1.0/24’를 할당하면 된다. 그러나 호스트가 300개인 네트웍을 위해서는 C클래스 2개를 할당하면, 그 네트웍은 2개의 네트웍으로 분리되어 버린다. 이런 사유로 호스트 IP 65535개인 B클래스를 1개 할당해 주어야 하는데, 이때 300개의 IP를 쓰고나면 65235개의 IP가 버려진다는 것이다. 이를 해결하기 위해 나온 개념이 바로 클래스리스(classless)이다.

  

클래스리스는 말 그대로 클래스의 개념이 없다라는 의미이다. , 기존에 정의되었던 A, B, C 클래스의 개념이 완전 없어진다. 대신에 IP 어드레스에서 네트웍과 호스트 영역을 구분해주는 식별자로 서브넷 마스크(subnet mask)의 개념이 도입된다. 서브넷 마스크는 ‘255.255.255.255’라는 형태로 제공되는데, 호스트의 수가 256개인 네트웍의 서브넷 마스크는 ‘255.255.255.0’ 또는 ‘/24’라는 형태로 표기할 수도 있다. 이런 사유로 클래스풀에서는 IP 라우팅에서 서브넷 마스크 정보를 전달하지 않지만, 클래스리스에서는 IP 라우팅시에 반드시 서브넷 마스크 정보를 전달하여 IP에서 네트웍 영역과 호스트 영역을 구별할 수 있게 해준다.

 

 

② 서브넷 마스크(Subnet Mask)의 이해

 

클래스리스에서는 해당 네트웍에 포함된 호스트의 수를 적절히 조절할 수 있으므로 두가지 장점이 있다. 첫번째 장점은 IP 어드레스의 낭비를 막을 수 있다는 것이고, 두번째 장점은 네트웍이 지나치게 커지는 것을 막아 불필요한 패킷 송수신을 막고 네트웍 단위의 기본적 보안도 제공해 줄 수 있다는 것이다.

 

결국 기존의 클래스개념이 없어지는 대신에 네트웍과 호스트 영역을 구분하기 위한 식별자로 서브넷 마스크가 도입되었다. 클래스풀에서는 통신시에 패킷에 단순히 IP 어드레스만 담아 전달하지만 클래스리스에서는 여기에 서브넷 정보까지 포함하여 전달한다.

 

예를들어 ‘1.2.3.4’라는 IP가 존재한다고 가정하자. 클래스풀에서는 첫 옥텟인 ‘1’이 네트웍을 의미하고 ‘1.0.0.0~1.255.255.255’까지가 사용가능한 IP 대역이다. 만약 200여개의 IP가 필요한 네트웍이 있다면, 기존의 클래스풀 개념에서는 C클래스인 ‘192.168.0.0’ 네트웍에서 ‘192.168.255.0’까지의 256개 네트웍만 사용이 가능했다. 그러나 클래스리스 개념에서는 ‘1.2.3.4’도 서브넷 마스크를 도입하여 ‘1.2.3.4 255.255.255.0’이라는 형태를 표기할 수 있다. 이때는 첫 세 옥텟인 ‘1.2.3’은 네트웍을 의미하고 마지막 네번째 옥텟인 ‘4’가 호스트의 고유 어드레스를 나타낼 수 있다.

 

참고로 클래스풀을 사용하는 라우팅 프로토콜로는 RIP version 1이 있는데, 이는 서브넷 정보를 전달하지 않으므로 IP를 정확히 계층적으로 디자인 하지 않으면 라우팅 이슈가 발생할 가능성이 높다.

 

 

VLSM(Variable Length Subnet Masking)의 이해

 

서브넷 마스크를 사용하면 클래스의 개념이 없어지기 때문에 기존의 A클래스와 B클래스도 C클래스처럼 사용이 가능하다. 이는 상당히 중요한데, 대부분의 네트웍은 호스트가 256이하의 수로 이루어지기 때문에 일반적으로 대부분 C클래스 크기의 네트웍으로 사용되어 진다. 그러나 사실 대부분의 네트웍은 256개보다도 훨씬 더 적은 호스트의 수로 이루어진다. , 수개에서 수십개 수준의 호스트만이 존재하는 네트웍을 위해 C클래스를 위한 256개의 호스트 IP 어드레스를 할당해 주는 것은 IP의 낭비를 초래한다. 이런 때에는 C클래스를 더 작게 나누어 사용하면 된다.

 

<C Class 4개로 나누는 경우>

네트웍

가용 IP

Start IP

End IP

1.1.1.0/26

64

1.1.1.0

1.1.1.63

1.1.1.64/26

64

1.1.1.64

1.1.1.127

1.1.1.128/26

64

1.1.1.128

1.1.1.191

1.1.1.192/26

64

1.1.1.192

1.1.1.255

 

그런데 어떤 빌딩에 100명의 직원을 가진 X사가 있고, 50명의 직원을 가진 Y, 25명의 직원을 가진 Z사가 있다고 가정해 보자. 이 빌딩 직원 전체의 수는 175명이므로 256개의 호스트를 가진 C클래스를 하나만 받으면 된다. 그러나 당연히 보안 사유로 각각의 회사의 직원들끼리는 통신이 되어서는 안된다. 그렇다면 X, Y, Z회사는 모두 256개의 호스트를 가진 C클래스를 따로 받아야 하므로 결국 ‘256*3’ 768개의 IP를 할당해 주어야 한다. 이때는 768개의 IP중에 175개의 IP만 사용하게 되므로 결국 593개의 IP가 낭비되게 된다.

이 경우에 이 빌딩을 위해 C클래스를 하나만 받은 상태에서, 다시 이 서브넷을 더 작게 나누어 사용한다면 IP는 훨씬 효율적으로 사용이 가능하게 된다. 이를 가능하게 하는 것이 VLSM(Variable Length Subnet Masking)으로 우리말로는 가변 길이 서브넷 마스킹이라고 부른다. VLSM은 하나의 서브넷을 다시 더 작게 나누어 쓸 수 있는 기술인데, 이때 나뉜 서브넷은 다양한 크기로도 나뉘어 공존할 수 있다는 것이다.

 

IP 어드레스는 2진수로 구성되기 때문에 서브넷을 나눌때는 항상 2의 배수 형태로 나뉘어야 한다. 그러므로 위의 경우에는 먼저 전체적으로 C클래스를 하나 할당 받은 후에 X사에게는 128(25bit), Y사에게는 64(26bit), Z사에게는 32(27bit)를 할당해 주면 된다. 이를 정리하면, 아래와 같다.

  

[– VLSM을 사용한 서브넷 구분]

네트웍

가용 IP

Start IP

End IP

1.1.1.0/25 (X)

128

1.1.1.0

1.1.1.127

1.1.1.128/26 (Y)

64

1.1.1.128

1.1.1.191

1.1.1.192/27 (Z)

32

1.1.1.192

1.1.1.223

1.1.1.192/27 (예비)

32

1.1.1.224

1.1.1.255

  

결국 VLSM을 사용하면 하나의 A, B 또는 C클래스를 다시 2의 배수 형태 이내에서 다양한 길이의 서브넷으로도 나눌수가 있다

 

 

CIDR(Classless Inter Domain Routing)의 이해

 

CIDR VLSM의 반대 개념이다. VLSM은 큰 서브넷을 더 작은 크기의 가변 길이를 가진 서브넷으로 나누는 개념이지만, CIDR C클래스처럼 작은 서브넷을 여러 개 합해서 한 개의 큰 서브넷으로 만드는 개념이다.

 

, 500개의 호스트가 있는 K사가 있고, 이 회사의 모든 직원들의 PC는 모두 한 개의 서브넷으로 간주되어 라우터 없이 통신이 가능해야 한다고 가정해 보자. 예를들어 만약에 C클래스를 두개 할당받아 ‘192.168.0.0/24’‘192.168.1.0/24’로 각각 운영한다면 직원들 서브넷이 두개가 되므로 문제가 된다. 이 경우에 만약에 위처럼 서브넷 두개가 연속되어 존재한다면 ‘192.168.0.0/23’처럼 한 개로 통합할 수가 있다.

 

결국 VLSM나눈다는 개념이라면, CIDR통합한다는 개념이다. 물론 아무 네트웍이나 무조건 합칠 수는 없지만, 2^n으로 이루어진 연속된 Network라면 무리없이 합칠 수 있다.

 

[– CIDR 사용하기 이전]

네트웍

가용 IP

Start IP

End IP

192.168.0.0/24

256

192.168.0.0

192.168.0.255

192.168.1.0/24

256

192.168.1.0

192.168.1.255

 

CIDR을 사용한다면 2의 배수로 이루어진 연속적인 네트웍을 아래처럼 한 개로 통합할 수 있다.

 

[– CIDR을 사용한 이후]

네트웍

가용 IP

Start IP

End IP

192.168.0.0/23

512

192.168.0.0

192.168.1.255

 

  

⑤ 정리

 

지금까지 언급한 내용을 간단한 표로 정리해 보자.

 

[서브넷 관련 기술]

CLASS 유무

Subnet 구분

기술

특징

Classful

-

-

Subnet 개념은 있음

Classless

Subnetting

Subnet Masking

Classful 무시

VLSM

가변길이 Subnetting

CIDR

가변길이 Aggregating

 

 

3) 문제 풀이

 

CCIE R&S에서 다루는 모든 문제는 IP 어드레스 관련되어 있다. 특히 정확한 IP 어드레스에 대한 이해를 요구하는 문제로는 엑세스 리스트, NAT, 라우트 필터 등이 있다. 그러나 이 내용들은 다른 곳에서도 반복하여 다루고 있으므로 여기서는 조금 생소한 헬퍼 어드레스에 대한 문제를 풀어 보도록 하자.

 

일반적으로 CCIE R&S 시험에서는 서버 또는 호스트를 다루지 않는다. 그러나 일부 문제는 서버와 호스트가 존재한다는 가정하에 문제 풀이가 진행된다. 이런 맥락에서 이번에는 BOOTP 서버와 클라이언트가 존재한다는 가정하에 문제를 풀어보자. 참고로 누구에게나 익숙한 DHCP 프로토콜은 BOOTP 프로토콜의 일종이므로 이를 대상으로 문제풀이를 하여 보자.

 

뒤의 DHCP 파트에서 설명하겠지만, 한번도 IP를 가지지 못한 DHCP 클라이언트는 DHCP 서버의 IP를 알지 못하므로 브로드캐스트 형태로 아무에게나 IP를 요청한다. 그로나 일반적으로 브로드캐스트 패킷은 라우터와 같은 레이어 3장비를 통과할 수 없다. 이런 사유로 라우터가 브로드캐스트 형태의 DHCP 또는 BOOTP 패킷을 수신할 경우에는 이를 무시하고 버리게 된다. 그러므로 라우터가 브로드캐스트를 수신시에 이를 버리지 않고 관리자가 원하는 서버로 전달하기 위해서는 유니캐스트로 변환하여 다른 라우터나 서버로 릴레이 해 줄 필요가 있다. 이 기능이 헬퍼 어드레스(helper-address)의 역할이다.

 

[출제유형 1 – UDP Broadcast Management 설정]

구분

내용

토폴로지

출제유형

BOOTP 서버는 R1 F0/1 VLAN_BB1(11)에 연동되어 있고 IP 150.1.1.200이다. BOOTP 클라이언트는 R1 F0/0 VLAN_12(12)에 연동되어 있다. R1은 클라이언트가 보낸 BOOTP 브로드캐스트를 서버에게 전달해야 한다.

설명

R1에서 BOOTP 클라이언트가 발신한 브로드캐스트를 수신하였을 경우, 헬퍼 어드레스를 사용하여 이를 유니캐스트로 변환후에 서버에게 전달한다.

솔루션

[R1]

ip forward-protocol udp bootpc

interface FastEthernet0/0

 ip helper-address 150.1.1.200

결과값

[R1]

R1#show ip helper-address fastEthernet 0/0

Interface                  Helper-Address  VPN VRG Name             VRG State

FastEthernet0/0            150.1.1.200     0   None                 Unknown

 

참고로 BOOTP 패킷이 아닌 SNMPtrap을 전달하려면 아래와 같이 설정하면 된다. 포워드 프로토콜을 SNMPtrap로 변경해 주면 된다. , 프로토콜을 ip forward-protocol udp snmptrap’으로 설정하고 나머지값은 그대로 두면 된다.

 

 

 

 2. DHCP

 

1) Concept

 

IP 환경에서 네트웍 장비나 호스트에 IP를 할당하는 방법은 두가지이다. 먼저 관리자가 IP와 서브넷등의 정보를 직접 스테틱하게 입력하는 방법이 있다. 그러나 관리하에 있는 호스트가 수백, 수천대라면 관리자가 일일이 IP를 입력하고 그 할당 리스트를 가지고 관리한다는 것은 상당히 어려운 일이다. 또한 정상적으로 IP를 스테틱하게 입력하였다고 하더라도 네트웍 정책등이 바뀌어 IP가 바뀌어야 한다면 전체 네트웍의 IP를 다시한번 바꾸어야 하는 번거로움이 있다.

 

이를 해결하기 위해 제안된 기능이 DHCP이다. DHCP‘Dynamic Host Configuration Protocol’의 약자로 호스트(PC)나 라우터의 NIC(Network Interface Card)에 인터넷 통신을 하기 위한 IP와 각종 옵션들을 자동으로 할당해주는 프로토콜이다. DHCP를 위한 구성요소는 DHCP 클라이언트(client), DHCP 서버(server)  그리고 경우에 따라서는 릴레이 에이전트(relay agent)도 필요하다.

 

DHCP 서버는 DHCP 클라이언트인 호스트들에게 IP와 각종 옵션들을 자동으로 할당해 줄 수 있다. 또한 클라이언트가 로그오프 하거나 IP 임대시간이 만료되었을 경우에는 자동적으로 IP를 회수하는 기능도 갖고 있다. 릴레이 에이전트는 위에서 보았듯이 헬퍼 어드레스를 사용하여 DHCP 패킷을 전달해 주는 라우터등을 의미한다.

 

 

2) 동작 원리

 

DHCP 클라이언트란 IP를 필요로 하는 장비를 의미하며 일반적으로 IP를 필요로 하는 PC의 랜카드나 라우터의 인터페이스를 의미한다. DHCP 서버란 IP 및 여러가지 옵션들을 할당해주는 장비를 의미하는데, 스위치나 라우터에서 관리자가 서버 기능을 활성화 시켜줌으로써 사용이 가능하다.

 

IP가 필요한 DHCP 클라이언트는 DHCP 서버의 위치를 알지 못하므로 브로드캐스트 형식으로 ‘DISCORVER’ 패킷을 보낸다. 이를 수신한 DHCP 서버는 자신이 IP를 할당해 줄 수 있음을 알리는 ‘OFFER’ 패킷을 보낸다. DHCP 클라이언트가 ‘OFFER’ 패킷을 수신하면 이번에는 브로드캐스트가 아닌 유니캐스트 형식으로 그 DHCP 서버를 지목하여 ‘REQUEST’ 패킷을 전달한다. DHCP 서버가 최종적으로 확인을 위한 ‘ACKNOLEDGE’ 패킷을 DHCP CLIENT에게 던져주면 IP 할당은 마무리 되고 DHCP 옵션 필드의 ‘leases time’ 만큼의 시간만큼 IP 사용이 가능해 진다.

 

[그림 – DHCP 아키텍처]

※ 그림 출처 : BSCI

 

만약에 DHCP 클라이언트가 수백을 넘는 다수이고, 보다 정확한 인증이 필요하거나 DB등의 관리가 필요하다면 별도의 유닉스나 윈도우 서버 기반의 플랫폼을 도입하는 경우가 많다. 그런데 DHCP에서 사용하는 bootp 프로토콜은 브로드캐스트 방식을 사용하므로 스위치 기반의 랜 환경에서는 사용이 가능하지만, 레이어 3의 라우터가 있는 환경에서는 프레임이 통과하지 못한다.

 

이 경우에 DHCP 클라이언트가 보낸 브로드캐스트 패킷을 드롭하지 않고 자신에게 지정된 DHCP 서버의 IP로 릴레이 해주는 역할을 하는 라우터를 릴레이 에이전트(relay-agent)라고 일컽는다.

 

[그림 – DHCP 릴레이 에이전트(헬퍼 어드레스 설정)]

※ 그림 출처 : BSCI

 

CCIE R&S 시험에서는 일반적으로 별도의 DHCP 서버없이 임의의 라우터에 DHCP 서버 기능을 활성화 시키라고 출제된다. 그리고 경우에 따라서는 특정 라우터에서 릴레이 에이전트 기능을 활성화 시키라고 출제되기도 한다.

 

 

3) 문제 풀이

 

[출제유형 1 – DHCP 서버 설정]

구분

내용

토폴로지

출제유형

R1에서 VLAN 12에 포함된 호스트를 위한 DHCP 서버 설정을 하라. 설정 조건은 아래와 같다.

ⓐ 현재 사용중이지 않은 IP DHCP 클라이언트에 할당할 수 있다.

DOMAIN NAME : cisco.com

DNS : yy.yy.12.100, yy.yy.12.200

LEASES TIME : 10시간

DEFAULT-ROUTE : R2 R1 down 되었을 때만 D/R로 사용한다.

ⓕ 신뢰된 MAC 어드레스로부터의 ARP 요청에 대해서만 응답해라.

설명

R1 R2 IP, 그리고 DNS IP는 클라이언트에 할당하지 말라는 의미이다. Excluded-address에서 R1 R2 IP는 한줄로 적을 수 있다. 그러나 한줄로 적으면 범위라는 의미가 되므로 DNS IP는 두줄로 각각 별도로 적어야 한다.

ⓑ 그대로 입력한다.

ⓒ 그대로 입력한다.

LEASES TIME는 그대로 설정한다. 시험 문제에서 leases time이 무한대라고 한다면, infinity로 입력하면 된다.

DEFAULT ROUTER를 이중화하란 의미로, R1 PRIMARY이고 R2 SECONDARY이다. R1 R2 IP를 순서대로 기술하면 된다.

ARP 인증을 하면 된다.

솔루션

[R1]

ip dhcp excluded-address 1.1.12.1 1.1.12.2

ip dhcp excluded-address 1.1.12.100

ip dhcp excluded-address 1.1.12.200

ip dhcp pool DHCP-POOL

 network 1.1.12.0 /24 (or 1.1.12.0 255.255.255.0)

 domain-name cisco.com

 dns-server 1.1.12.100 1.1.12.200

 lease 10

 default-router 1.1.12.1 1.1.12.2

 update arp

!

Interface fastEthernet 0/0

 arp authorized

결과값

생략


 

 

3. HSRP

 

1) Concept

 

HSRP‘Hot Standby Redundancy Protocol’의 약자로 호스트나 또 다른 라우터들에 대해 게이트웨이 역할을 하는 IP를 여러대의 라우터가 가지고 공유하여 싱글 포인트(single point)에 대한 장애에 대한 이중화 역할을 담당하기 위해 제안된 프로토콜이다. HSRP는 게이트웨이 IP를 이중화하기 위해 시스코사가 제안한 프로토콜로 비표준이며, 표준 프로토콜로는 VRRP(Virtual Router Redundancy Protocol)가 있다. 그외에 유사한 기능으로 서버 로드 밸런싱이 가능한 GLBP(Gateway Load Balancing Protocol)와 게이트웨이 IP를 호스트들에게 전달할 수 있는 IRDP(ICMP Router Discovery Protocol)도 있다.

 

라우터나 MLS 스위치는 라우팅 프로토콜이나 STP등을 활용하여 네트웍 장비와 경로에 대한 이중화가 가능하다. 그러나 일반적으로 호스트는 게이트웨이를 한 개만 적용하므로 자신의 게이트웨이로 설정된 라우터의 인터페이스가 다운되면 다른 네트웍으로의 통신이 단절된다. 예를들어 네트웍 ‘192.168.100.0/24’에 속한 모든 호스트들은 게이트웨이인 ‘192.168.100.1/24’가 다운된다면 타 네트웍으로의 통신이 불가할 것이다. 이에 대한 대안이 바로 HSRP와 같은 게이트웨이 이중화 프로토콜들이다.

 

 

2) 동작원리

 

HSRP는 단일 서브넷에서 사용될 게이트웨이 IP를 여러대의 라우터가 공유하는 방식이다. 이때 라우터들은 최초에 협상 과정을 통해 단 한대의 라우터만을 액티브(active)로 선출하고 나머지 라우터들은 스탠바이(standby) 라우터로 동작한다. 만약 액티브 라우터에 문제가 발생하였을 경우에는 스탠바이 라우터들이 액티브로 승격된다.

 

[그림 – HSRP 원리]

※ 출처 시스코

 

액티브 라우터와 스탠바이 라우터는 기본적으로 4초 단위로 주기적으로 SYNC를 교환한다.  액티브 라우터는 이 게이트웨이 IP(virtual IP)와 게이트웨이 MAC(virtual MAC) ARP로 전달한다. 액티브 라우터의 선정은 기본적으로 우선순위(priority)에 의해 결정된다. 액티브 라우터가 선출되면 나머지 라우터들은 모두 스탠바이 상태에 머문다. 참고로 HSRP에서 ‘priority’ 기본값은 ‘100’이지만 관리자가 ‘1~255’ 이내에서 설정이 가능하며 높을수록 우선한다.

 

HSRP는 로드 밸런싱이 가능하다. 하나의 서브넷에서 두개의 게이트웨이 IP를 운영하는 방식으로 MHSRP(Multi HSRP)라고 한다. 한 개의 서브넷에 R1 R2가 있다면 두 라우터 모두에 게이트웨이 IP A B를 설정한다. R1 IP A에 대해 액티브이고 B에 대해 스탠바이로 동작하고 R2는 반대로 설정한다. 그후에 호스트들을 2로 나누어 각각 A B를 게이트웨이로 바라보게 설정하면 된다.

 

[그림 – MHSRP 원리]

 

HSRP는 트래킹(tracking)이 가능하다. HSRP가 정상적으로 동작하는 라우터이더라도 만약 백본으로 향하는 업링크 인터페이스가 다운된다면 호스트들은 상위 네트웍이나 인터넷으로 통신이 불가능해진다. 게이트웨이 역할의 HSRP 라우터에서 특정 인터페이스를 트래킹 설정하면, 그 인터페이스가 다운될 경우 일종의 패널티를 부과할 수 있으므로 액티브의 권한을 포기하게 할 수 있다. 물론 이때 재협상 과정을 통해 스탠바이 라우터가 액티브로 승격된다.

 

VRRP, GLBP, IRDP HSRP와 거의 유사하므로 별도의 설명은 생략하기로 한다. 그래도 뒤의 문제풀이에서 간단한 설정과 설명을 다루고 있으니 이를 참조하기 바란다. 참고로 표준 프로토콜인 VRRP MVRRP 기능으로 로드 밸런싱이 가능하다. HSRP VRRP는 유사하면서도 몇가지 차이점이 있는데 아래 표를 참조하도록 한다.

 

[– HSRP VRRP 차이점]

비교 항목

HSRP

VRRP

엑티브 라우터 이름

엑티브/스탠바이 라우터

마스터/백업 라우터

그룹범위와

우선순위 범위

그룹 : 0 ~ 255

우선순위 : 0 ~ 255 (기본 100)

그룹 : 0 ~ 255

우선순위 : 1 ~ 254 (기본 100)

Virtual Router

MAC

0000.0c07.acxx

(xx는 그룹번호)

0000.5e00.01xx

(xx는 그룹번호)

메시지 간격

HSRP Hello : 3

VRRP Ad : 1

Preempt

구현 가능여부

가능

가능

인터페이스

트래킹 기능

가능

불가

※ 출처 시스코

 


 

3) 문제 풀이

 

HSRP

 

HSRP는 앞서 언급했듯이 두대 이상의 라우터가 동일한 서브넷에 대해 한 개의 게이트웨이 IP를 공유하는 방식이다. 일반적으로 한대의 라우터가 액티브 상태를 유지하고 다른 한대의 라우터는 스탠바이 상태를 유지하므로 로드 밸런싱이 되지 않지만, MHSRP를 사용하여 두개의 VIP(Virtual IP) 를 설정하면 로드 밸런싱도 가능하다.

 

[출제유형 1 – HSRP 설정]

구분

내용

토폴로지

출제유형

VLAN 12에 존재하는 호스트를 위해 HSRP를 설정하고 로드 밸런싱이 가능하도록 하라. , R1 R2 모두 업링크를 위한 S0 인터페이스가 다운될 경우에는 게이트웨이 기능을 포기해야 한다.

설명

VIP를 두개 설정하면 된다. 시험에서 VIP를 지정하지 않는다면 임의의 VIP를 사용하면 되므로 여기서는 yy.yy.12.3 yy.yy.12.4를 사용하도록 하자. S0 인터페이스를 트랙킹 설정하여 인터페이스가 다운될 경우에는 패널티를 주도록 한다. 이중화시에 ‘preempt’를 설정하면 R1이 장애에서 원복될 경우 다시 ACTIVE 기능을 가져온다.

솔루션

[R1]

interface FastEthernet0/0

 ip address 1.1.12.1 255.255.255.0

 standby 1 ip 1.1.12.3

 standby 1 preempt

 standby 1 priority 110

 standby 1 track s1/0 20

standby 2 ip 1.1.12.4

 standby 2 preempt

 

[R2]

interface FastEthernet0/0

 ip address 1.1.12.2 255.255.255.0

standby 1 ip 1.1.12.3

 standby 1 preempt

 standby 2 ip 1.1.12.4

 standby 2 preempt

 standby 2 priority 110

 standby 2 track s1/0 20

결과값

[R1]

R1#show standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP    

Fa0/0       1   90   P Standby  1.1.12.2        local           1.1.12.3      

Fa0/0       2   100  P Active   local           1.1.12.2        1.1.12.4

 

[R2]

R2#show standby brief

                     P indicates configured to preempt.

                     |

Interface   Grp Prio P State    Active          Standby         Virtual IP    

Fa0/0       1   100  P Active   local           1.1.12.1        1.1.12.3      

Fa0/0       2   90   P Standby  1.1.12.1        local           1.1.12.4

 


 

VRRP

 

시스코 소유의 HSRP와는 달리 표준 프로토콜인 VRRP HSRP와 그 설정이나 기능이 유사하다. 먼저 VRRP는 표준 프로토콜이므로 이기종 벤더 장비간에도 호환이 가능하다. 또한 HSRP VIP를 별도로 준비해야 하지만 VRRP는 라우터의 물리적인 IP를 그대로 사용할 수 있는 장점이 있다. 예를들어 R1이 가진 ‘1.1.12.1/24’라는 IP VIP로 사용한다면, HSRP 네이버의 우선순위(priority)에 관계없이 VIP의 실제 주인인 R1이 무조건 액티브로 동작한다.

 

[출제유형 1 – VRRP 설정]

구분

내용

토폴로지

출제유형

VLAN 12에 존재하는 호스트를 위해 VRRP를 설정하라. 그러나 이를 위해 별도의 VIP를 사용하면 안되며, 항상 R1이 먼저 액티브가 되어야 한다. 그리고 가장 강력한 인증을 사용해야 한다.

설명

R1 IP를 그대로 VIP로 사용하면 된다. VRRP priority도 기본값이 100이지만 R1 f0/0 IP VIP로 사용하면 무조건 R1이 액티브가 된다. HSRP와 달리 ‘preempt’ 기능이 기본적으로 활성화 되어 있으므로 설정하지 않아도 된다. 가장 강력한 인증은 ‘md5’ 방식이다.

솔루션

[R1]

interface FastEthernet0/0

 ip address 1.1.12.1 255.255.255.0

 vrrp 1 ip 1.1.12.1

 vrrp 1 authentication md5 key-string cisco

 

[R2]

interface FastEthernet0/0

 ip address 1.1.12.2 255.255.255.0

 vrrp 1 ip 1.1.12.1

 vrrp 1 authentication md5 key-string cisco

결과값

[R1]

R1#show vrrp brief

Interface          Grp Pri Time  Own Pre State   Master addr     Group addr

Fa0/0              1   255 3003   Y   Y  Master  1.1.12.1        1.1.12.1  

 

[R2]

R2#show vrrp brief

Interface          Grp Pri Time  Own Pre State   Master addr     Group addr

Fa0/0              1   100 3609       Y  Backup  1.1.12.1        1.1.12.1

 


 

GLBP

 

MHSRP MVRRP는 기본적으로 로드 밸런싱을 위해 여러 개의 그룹을 만들어야 한다. 이를 보완하기 위해 제공된 프로토콜이 GLBP로 이는 표준이 아닌 시스코에 의해 제안된 기능이다. 라우터들 사이에서 패킷의 로드 셰어링(Load Sharing)을 수행하고 동시에 백업 라인 구성이 가능한 프로토콜이다.

 

호스트들은 동일한 한 개의 가상 IP(virtual IP)만 게이트웨이로 설정한다. 그리고 동일한VIP를 가진 그룹 내에 모든 라우터들은 동시에 패킷 스위칭이 가능한 방식이다. 로드 밸런싱 방법은 아래의 세가지가 있다.

 

Round Robin

: Host가 디폴트 게이트웨이 Mac을 질의할 때, AVF Virtual Mac 주소를 순서대로 응답

Weighted

: AVF마다 다른 가중치를 구현하여 로드밸런싱

Host-dependent

: 특정 Host들에게 항상 특정 AVF Virtual Mac 주소로 응답하는 방법

 

[출제유형 1 – GLBP 설정]

구분

내용

토폴로지

출제유형

VLAN 12에 존재하는 호스트를 위해 게이트웨이 이중화를 설정하라. 이때 한 개의 VIP만을 사용해야 하며, 라우터간에는 로드 밸런싱을 지원해야 한다.

설명

GLBP를 사용하면 된다.

솔루션

[R1]

interface FastEthernet0/0

ip address 1.1.12.1 255.255.255.0

glbp 1 ip 1.1.12.3

glbp 1 priority 150

glbp 1 preempt

 

[R2]

interface FastEthernet0/0

 ip address 1.1.12.2 255.255.255.0

 glbp 1 ip 1.1.12.3

 glbp 1 priority 50

 glbp 1 preempt

결과값

[R1]

R1#show glbp brief 

Interface   Grp  Fwd Pri State    Address         Active router   Standby route

Fa0/0       1    -   150 Active   1.1.12.3        local           1.1.12.2     

Fa0/0       1    1   7   Active   0007.b400.0101  local           -

Fa0/0       1    2   7   Listen   0007.b400.0102  1.1.12.2        -

 

[R2]

R2#show glbp brief

Interface   Grp  Fwd Pri State    Address         Active router   Standby route

Fa0/0       1    -   50  Standby  1.1.12.3        1.1.12.1        local        

Fa0/0       1    1   7   Listen   0007.b400.0101  1.1.12.1        -

Fa0/0       1    2   7   Active   0007.b400.0102  local           -

 


 

IRDP

 

일반적으로 호스트는 자신이 소속된 서브넷의 게이트웨이 IP를 알지 못한다. 이런 사유로 관리자는 DHCP 서버를 사용하지 않는 이상 게이트웨이 IP는 확인 및 설정이 어렵다. IRDP를 사용하면 라우터는 호스트에게 게이트웨이 IP를 할당할 수 있다. 그러나 이 기능을 사용하기 위해서는 게이트웨이 역할을 하는 라우터에서 IRDP 기능을 활성화 해야하고, 호스트도 IRDP 프로토콜을 사용해야 한다.

 

대부분의 Host들은 IRDP(ICMP Router Discovery Protocol)을 사용하지 않지만, Windows 2000의 경우 IRDP Message IRDP가 설정된 라우터의 인터페이스에 보내어 게이트웨이 IP를 자동으로 설정하게 할 수 있다.

 

[출제유형 1 – IRDP 설정]

구분

내용

토폴로지

출제유형

VLAN 12에 존재하는 호스트를 위해 게이트웨이 이중화를 설정하라. 라우터에서 게이트웨이 IP를 할당해 줄 수 있어야 한다. 또한 R1 ACTIVE가 되기위한 최고값으로, R2 ACTIVE가 되기 위한 최저값으로 설정하라.

설명

GLBP를 사용하면 된다.

솔루션

[R1]

interface FastEthernet0/0

ip address 1.1.12.1 255.255.255.0

ip irdp

ip irdp preference 2147483647

 

[R2]

interface FastEthernet0/0

 ip address 1.1.12.2 255.255.255.0

 ip irdp

 ip irdp preference -2147483648

결과값

[R1]

R1#show ip irdp fastEthernet 0/0

FastEthernet0/0 has router discovery enabled

 

Advertisements will occur between every 450 and 600 seconds.

Advertisements are sent with broadcasts.

Advertisements are valid for 1800 seconds.

Default preference will be 2147483647.

 

[R2]

R2#show ip irdp fastEthernet 0/0

FastEthernet0/0 has router discovery enabled

 

Advertisements will occur between every 450 and 600 seconds.

Advertisements are sent with broadcasts.

Advertisements are valid for 1800 seconds.

Default preference will be -2147483648.

 

 


4. IP services

 

1) Concept

 

IP 서비스는 상당히 광범위한 표현이다. 사실 IP 서비스라함은 라우터에서 구동이 가능한 대부분의 기능을 의미한다. 시스코 홈페이지에서 IP 서비스를 검색하면 시스코 라우터가 할 수 있는 많은 기능들이 정리되어 있다. 그 내용으로는 DNS, DHCP, NAT, HSRP등 그 종류도 다양하다. 이런 내용들은 본글의 많은 곳에서 거론이 디므로 여기서는 조금 생소한 웹 캐싱 기능을 학습해 보자.

 

 

2) 동작 원리

 

웹 캐싱이란 웹 서버 과부하에 의한 웹 트래픽을 감소시키기 위해 사용자가 웹 검색을 할 때 대기시간을 줄이는 기술을 말한다. , 자주 찾는 웹 사이트나 파일을 로컬상의 캐시(cache) 시스템 등에 저장해 두고, 필요한 경우에는 해당 웹사이트에 접속하지 않고 로컬의 임시 저장 서버에 바로 접속해 검색 속도를 향상 시키고 회선 비용 부담을 줄이는 기술이다.

 

예를 들자면, 시스코 코리아 지사에서 임직원들이 www.cisco.com에 접속하려면 한국 ISP를 거쳐 미국의 서버에 접속해야 할 것이다. 일회성의 접속이라면 문제없지만, 매일 수많은 접속을 한다면 국제 회선의 부하가 상당히 크게 되고 또한 그 딜레이로 인한 속도도 상당히 느릴 것이다. 만약 시스코 코리아의 내부에 웹 캐싱 서버를 둔다면 속도 향상 및 회선 비용을 줄일수 있을 것이다. 웹 캐싱 시스템이 라우터에 접속되어 있다면, 라우터에서는 www.cisco.com으로 가는 패킷을 웹 캐싱 시스템으로 리다이렉트 시키는 설정을 해야 한다.

 

 

3) 문제 풀이

 

라우터에 웹 캐싱 시스템을 연동하여 보자.

 

[출제유형 1 – 웹 캐싱 시스템 설정]

구분

내용

토폴로지

출제유형

R1 F0/0이 속한 VLAN에 웹 캐싱 시스템을 도입할 예정이다. R1 F0/0에서의 HTTP 트래픽을 인터셉트(intercept)하여 이를 캐시 엔진으로 전달하도록 하라.

설명

웹 캐싱 시스템 기능을 이용한다.

솔루션

[R1]

ip wccp web-cache

interface FastEthernet0/0

 ip wccp web-cache redirect out

 ip route-cache same-interface

결과값

[R1]

R1#show ip wccp interfaces detail

WCCP interface configuration details:

    FastEthernet0/0

        Output services: 1

        Static:          Web-cache

        Dynamic:         None

        Input services:  0

        Mcast services:  0

        Exclude In:      FALSE

 

 

 

5. IOS user interfaces

 

1) Concept

 

IOS는 시스코 라우터를 구동하는데 사용되는 OS를 의미한다. 인터페이스란 대화또는 의사 소통을 위한 매개체를 의미하는데, 일반적으로 시스코 라우터와 관리자를 연결시켜 주는 방법 정도로 정도로 생각하면 된다. 시스코 라우터와 스위치등의 제품군은 기본적으로 CLI(Command Line Interface) 방식으로 인터페이스를 제공하는데, 이는 관리자가 콘솔로 장비에 접속한 후에 텍스트로 이루어진 다양한 명령어 문구를 입력하는 방식이다. 이 외에도 SNMP를 이용하거나 HTTP를 이용해서도 접속과 제어가 가능하지만, 일반적으로 CLI 위주로 사용한다.

 

 

2) 동작 원리

 

앞서도 설명하였듯이 시스코 라우터들은 대부분 다양한 단어와 문구들의 조합으로 이루어진 수많은 명령어들의 조합으로 운영된다. 여기서는 IOS에서 사용하는 CLI를 학습하는 차원에서 엑세스 레벨별로 사용이 가능한 명령어를 정의해 보자.

 

 

3) 문제 풀이

 

IOS 사용에 있어 기본 유저에 대한 엑세스 레벨을 정의하고 적절한 권한을 정의해 본다.

 

[출제유형 1 – Privilege Level 설정]

구분

내용

토폴로지

출제유형

기본 유저의 엑세스 레벨에 대한 수정없이, level 5의 유저를 신규로 생성하고 패스워드를 cisco5로 설정해 보자. 이 유저는 아래 명령어만 사용이 가능하다.

- 실행된 debug 기능을 off 할 수 있다.

- ping 명령어를 사용할 수 있다.

- IP 어드레스를 추가 또는 제거가 가능하다.

- NVRAM상에 현재 설정을 저장할 수 있다.

설명

Privilege 기능을 이용한다.

솔루션

[R1]

enable secret level 5 cisco5

privilege exec level 5 undebug all

privilege exec level 5 ping

privilege exec level 5 copy running-config startup-config

privilege exec level 5 write memory

privilege exec level 5 configure terminal

privilege configure level 5 interface

privilege interface level 5 ip address

privilege interface level 5 ip

결과값

[R1]

R1>enable 5

Password: cisco5

R1#show privilege

Current privilege level is 5


 

 

6. System management

 

1) Concept

 

System Management란 라우터와 스위치에 대한 관리를 의미하지만 그 범위는 상당히 광범위하다. 일반적으로 SNMP, MIB, RMON, CDP, NetFlow Accounting, Syslog Accounting 등이 이 범위에 들어간다. 여기서는 SYSLOG에 대해서 다루어 보기로 하자.

 

2) 동작 원리

 

라우터에서는 자신에 대한 이벤트 메시지와 에러에 대한 레포팅을 할 수 있다. 사실 SYSLOG는 단순히 시스템 자신의 이벤트에 대한 레포팅의 용도이기 때문에 발생한 이벤트에 대한 제어를 목적으로 하지는 않는다. 이 이벤트 메시지는 아래와 같은 8단계의 레벨과 facility를 가진다. 문구에서도 알 수 있듯이 레벨 0으로 갈수록 위협적인 이벤트를 의미하고 레벨 7로 갈수록 단순한 정보 수순의 이벤트임을 나타낸다.

 

[– SYSLOG 레벨]

Emergency (0)

Alert (1)

Critical (2)

Error (3)

Warning (4)

Notice (5)

Informational (6)

Debugging (7)

 

관리자는 라우터에서 SYSLOG 기능을 활성화할 때 8개의 레벨에서 이벤트 기록 수준을 정할 수 있다. 라우터의 SYSLOG의 레벨은 절대적인 기준없이 개발자에 의해 정의된다. 물론 레벨 7 , ‘Debugging’을 설정한다면 라우터에서 발생하는 모든 SYSLOG 관련 이벤트에 대한 모니터링이 가능하지만 너무 많은 모니터링으로 인해 관리의 혼선을 초래한다. 실무에서는 일반적으로 레벨 3~5정도의 수준으로 운영하는데, 만약 레벨 3으로 설정한다면 상위의 레벨을 모두 포함한 0,1,2,3 모두의 이벤트 로그를 모두 SYSLOG상에서 볼 수 있다.

 

SYSLOG 레벨을 설정하고 나서는 이벤트가 저장될 서버를 지정할 수 있다. 만약 SYSLOG내용은 외부의 서버 또는 라우터 자신의 메모리에 저장할 수도 있다. SYSLOG를 자신의 메모리에 저장할 때는 저장할 용량의 사이즈도 결정할 수 있다. SYSLOG가 생성될 때는 time-stamp, level, facility가 함께 기록된다.

 

 

3) 문제 풀이

 

그럼 R1에서 SYSLOG를 설정해 보자.

 

[출제유형 1 – 서머 타임 설정]

구분

내용

토폴로지

출제유형

R1 에서 system error message를 아래 조건을 참조하여 local buffer 에 저장해야 한다.

Buffer 에는 emergency, alerts, critical, error 들이 저장된다.

buffer size 8192 byte로 설정하라.

ⓒ 각 log entry 에는 시간이 명시 되어야 한다.

설명

먼저 SYSLOG가 저장되는 서버를 local로 설정한다.

ⓐ 최소한의 SYSLOG 레벨은 error(4) 이다.

buffer size 8192 byte로 설정한다.

ⓒ 라우터에서 log에 대한 datetime 기능을 활성화 한다.

솔루션

[R1]

logging on

logging buffered 8192 error

!

service timestamps log datetime msec localtime

결과값

[R1]

R1#show logging

Syslog logging: enabled (11 messages dropped, 0 messages rate-limited,

(생략)

Log Buffer (8192 bytes):


 

 

7. NAT

 

1) Concept

 

NAT‘Network Address Translation’의 약자로 쉽게 말해 임의의 IP를 다른 IP로 변경해주는 프로토콜로 일반적으로 IP 부족의 해소와 보안의 용도로 주로 사용된다. NAT에서는 로컬을 의미하는 인사이드(inside)와 인터넷과 같은 외부 네트웍을 지칭하는 아웃사이드(outside)로 영역이 나뉘어 진다. 일반적으로 인사이드에서는 사설 IP, 아웃사이드에서는 공인 IP를 사용하지만 이는 관리자의 정책에 따라 변할 수 있다. NATIP 공유기와 파이어월(firewall)에서 가장 기본으로 사용되는 기능으로 IP 변환을 통해 보안이나 라우팅 이슈를 해결해 주는 역할을 담당한다. NAT에는 스태틱(정적; STATIC) NAT와 다이나믹(동적; DYNAMIC) NAT이 존재한다.

 

일반적으로 NAT IP 1:1로 변경해주는 반면, PAT1개 또는 소수의 공인 IP를 여러 개의 사설 IP가 공유해서 사용하는 N:1 또는 N:N 방식의 공유 기법이다. PAT‘Port Address Translation’의 약자로 IP 변환이라는 측면에서는 NAT와 유사하기 때문에 NAPT(Network Address Port Translation)이라고도 불리운다. PAT는 일반적으로 NAT 설정뒤에 ‘overload’라는 옵션의 지정으로 간단하게 설정이 가능하다.

 

 

2) 동작 원리

 

일반적으로 공인 IP는 해킹에 노출되기 쉽기 때문에 NAT을 사용하여 사설 IP로 변환하는 경우가 많다. NAT는 네트웍상의 DMZ 구간의 HTTP FTP 서버의 IP가 공격받는 것을 대비하기 위해 FIREWALL 상에서 스태틱 NAT등을 사용하여 IP 변환을 시키고, 이때 프락시(proxy) 역할을 한다. 사설 IP는 인터넷으로부터 직접적인 공격을 받지 않기 때문이다. PAT의 경우는 보안의 의미보다는 다수의 사설 IP 사용자들이 소수의 공인 IP를 공유하여 인터넷을 사용한다는 개념이 앞선다. 어쨌거나 NAT PAT의 사용 목적은 보안과 IP 공유의 두가지 목적이 가장 강하다.

 

앞서 설명했듯이 NAT에는 스태틱 NAT와 다이나믹 NAT이 있다. 스태틱 NAT은 일반적으로 임의의 IP 어드레스를 관리자가 지정한 다른 IP 어드레스로 1:1로 변환시켜주는 기능이다. 스태틱 NAT을 사용하면 IP 어드레스 이외에 임의의 포트 번호까지 같이 변환시켜 줄 수도 있다. 다이나믹 NAT은 일반적으로 N:N의 개념으로 특정 그룹의 IP 서브넷이 NAT가 설정된 라우터를 통화할 경우, IP 변환용으로 준비된 IP 서브넷 내의 임의의 IP로 변경되는 기능이다. 물론 NAT가 활성화된 라우터는 변환된 IP에 대한 테이블을 가지고 있으므로 되돌아오는 패킷에 대한 정확한 라우팅도 가능하다.

 

PAT의 경우, 인사이드의 사설 IP 254개이고 인터넷이 가능한 아웃사이드용 공인 IP 1개밖에 없다면, 254:1의 방식으로 공인 IP를 공유하게 된다. 만약 공인IP 10개라면 254:10의 방식으로 마찬가지로 공인 IP를 공유하게 된다. PAT 라우터에서 인사이드 IP가 아웃사이드 IP로 변환시에는 인사이드 IP들은 각각 포트 넘버를 부여받게 되고 라우터는 이를 테이블에 기록해 두는 방식이다.

 

 

3) 문제 풀이

 

여기서는 다이나믹 NAT에 대해 학습해 보기로 한다.

 

[출제유형 1 – NAT 설정]

구분

내용

토폴로지

출제유형

R1 F0/1 IP 1.1.18.1/24이고 VLAN_18에 포함되어 있다고 가정하자. 1.1.18.0/24 네트웍은 절대 타 장비로 광고되면 안된다. 이 상태에서 R1 Loopback 0 1yy.0.0.0/24 네트웍을 세컨드리 IP로 설정하고 이 네트웍을 아무 라우팅 프로토콜로 광고하라. 그후에 VLAN_18에 포함된 모든 네트웍이 Loopback 1 IP들을 이용하여 R2와 통신이 가능하게 설정해 보자.

설명

R1 F0/1은 인사이드, F0/0을 아웃사이드로 설정하고 NAT을 설정한다.

솔루션

[R1]

! IP 추가 설정

interface FastEthernet0/1

 ip address 1.1.18.1 255.255.255.0

!

interface Loopback0

 ip address 101.0.0.1 255.255.255.0 secondary

 ip address 1.1.1.1 255.255.255.255

 ip ospf network point-to-point

 

! 라우팅 추가 설정

router ospf 1

 router-id 1.1.1.1

 network 1.1.1.1 0.0.0.0 area 0

 network 1.1.12.1 0.0.0.0 area 0

 network 101.0.0.0 0.0.0.255 area 0

 

! NAT 설정

ip access-list standard NAT-INSIDE

 permit 1.1.18.0 0.0.0.255

!

ip nat inside source list NAT-INSIDE pool NAT-POOL

ip nat pool NAT-POOL 101.0.0.1 101.0.0.254 netmask 255.255.255.0

 

! NAT 적용

interface FastEthernet0/0

 ip nat outside

!

interface FastEthernet0/1

 ip nat inside

결과값

[R2]

! R1의 룹백0 세컨드리 IP로의 PING 테스트 (성공)

R2#ping 101.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 101.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/128/204 ms

 

! R2에서 R1 F0/1 IP로의 PING 테스트 (실패)

R2#ping 1.1.18.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.18.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

 

[R1]

! R1 F0/1 IP를 사용하여 R2 PING 테스트 (성공)

R1#ping 1.1.12.2 source 1.1.18.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.12.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.18.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/130/288 ms

 

! R1에서 NAT를 사용하여 IP가 변경된 결과

R1#show ip nat translations

Pro Inside global      Inside local       Outside local      Outside global

--- 101.0.0.1          1.1.18.1           ---                ---

 

만약에 변경(translation) IP 101.0.0.0 ~ 101.0.0.255의 서브넷 단위가 아닌 101.0.0.1와 같은 특정 IP 1개만 사용하려면 어떻게 해야 될까? 설정 방법은 매우 간단한데 ‘ip nat’ 명령어의 마지막에 ‘overload’만 추가해 주면 된다.


 

 

8. NTP

 

1) Concept

 

NTP‘Network Time Protocol’의 약자로 말 그대로 네트웍 장비들에 시간을 자동적으로 설정하거나 동기화하기 위해 사용하는 프로토콜이다. 물론 호스트와 라우터 모두 별도의 외부장비의 도움없이 관리자에 의해 임의로 시간 설정이 가능하지만, 네트웍 운영이나 장애 관리등을 위해서는 표준화된 정확한 시간 설정이 필요하다. 또한 경우에 따라서는 연동되는 장비들간에 정확한 싱크(sync)를 요구하는 경우도 있으므로 표준화된 정확한 시간 설정은 필수라고 볼 수 있다.

 

 

2) 동작 원리

 

시스코 라우터나 스위치는 외부에서 제공되는 NTP 서버에 대해 클라이언트로 동작이 가능하지만 관리자의 설정에 따라 다시 자신이 NTP 서버로도 동작할 수 있다. , NTP는 계층적인 구조로 운영이 가능하다는 의미이다. 예를 들어 R1이 인터넷에서 제공하는 NTP 서버에 클라이언트로 동작하는 상태에서 다시 R1 NTP 서버 기능을 활성화 시키면, R2 SW1등은 R1에 대해 NTP 클라이언트로 동작할 수도 있다는 것이다.

 

NTP 설정시에는 보안을 설정할 수도 있다. NTP 서버와 클라이언트는 모두 NTP를 연동시에 특정 인터페이스의 IP만을 사용해서 통신할 수도 있다. 이때는 해당 인터페이스를 ‘source interface’로 지정하면 되는데, 일반적으로 룹백 인터페이스를 사용한다.

 

 

3) 문제 풀이

 

R1 NTP 서버로, SW1 NTP 클라이언트로 설정해 보자.

 

[출제유형 1 – IRDP 설정]

구분

내용

토폴로지

출제유형

R1 NTP 서버로, R2 NTP 클라이언트로 설정해라. R1 NTP 서비스 제공을 위해 가장 신뢰할 수 있는 인터페이스를 사용해야 한다. R2는 룹백 0를 사용해야 하고 STRATUM 3으로 설정해야 한다. 그리고 가장 강력한 인증을 사용해야 한다.

설명

R1 R2 모두 룹백 0를 사용해야 한다.

ⓑ 스트라툼(STRATUM)을 적절히 조절한다.

MD5 인증을 사용한다.

솔루션

[R1]

ntp master 2

ntp source Loopback0

ntp authenticate

ntp authentication-key 1 md5 cisco

ntp trusted-key 1

 

[R2]

ntp server 1.1.1.1 key 1

ntp source Loopback0

ntp authenticate

ntp authentication-key 1 md5 cisco

ntp trusted-key 1

결과값

[R2]

R2#show ntp status    

Clock is synchronized, stratum 3, reference is 1.1.1.1

nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18

reference time is CD3B42C3.EB35E9F6 (00:03:15.918 UTC Tue Feb 10 2009)

clock offset is 244.6775 msec, root delay is 39.86 msec

root dispersion is 487.32 msec, peer dispersion is 242.61 msec

 


 

9. SNMP (/w RMON)

 

1) Concept

 

SNMP‘Simple Network Management Protocol’의 약자이다. 레이어3 통신을 위한 표준 IP의 개념이 생겼을 때에는 네트웍 장비들의 관리를 위해서 ICMP , ping을 사용하였다. 그러나 ICMP 프로토콜은 ping을 이용해 단순히 네트웍 장비의 정상 운영 여부만을 확인할 수 있었다. 네트웍과 IP가 발전함에 따라 관리를 위한 다양한 기능을 가진 전문적인 네트웍 관리 프로토콜이 필요하여 제작된 것이 바로 SNMP이다. 현재 SNMP는 보안 기능이 강화된 ‘SNMP version 3’까지 표준으로 제정되어 사용되고 있다.

 

RMON은 원격지의 통신망을 관리하도록 설계된 SNMP 기능을 확정하여 관리할 수 있도록 한 기능이다. 이는 SNMP를 이용하여 분산된 랜 환경에서 원격 모니터링 장비가 어떤 방법으로 통신망 데이터를 수집하여 저장할 것인지를 규정한다. RMON은 랜 프로토콜 분석기의 개념을 발전시켜 각 통신장비에 원격 모니터링 기능을 설치한다. 그후에 해당 통신 장비의 정보를 수집하여 NMS 등으로 전달하는 기능을 가진다. 참고로 RMON은 레이어 1 2에 대한 원격지 감시 기능도 제공한다.

 

 

2) 동작 원리

 

SNMP는 라우터와 스위치처럼 관리 대상이 되는 SNMP 에이전트(agent)와 이를 통합 관리하는 서버 형태의 관리용 서버(NMS; Network Management Server)로 구성된다. 라우터와 스위치도 간단한 SNMP 서버의 기능을 가질 수 있다. 그러나 일반적으로 라우터와 스위치는 관리가 되는 대상인 SNMP 에이전트로 동작시키고, 관리를 위한 NMS 서버는 별도의 시스템을 두어 운용한다.

 

SNMP는 시스템에 대한 제반 정보를 제공하므로 해커등에게 오픈 될 경우 공격의 대상이 될 수도 있다. 이런 사유로 SNMP에서는 여러가지 기본적인 보안 기능이 제공된다. SNMP  에이전트와 서버는 ‘community’라고 불리는 일종의 패스워드를 사용하여 통신한다. 또한 접근 권한을 RO(read-only)RW(read-write)로 구분하여 시스템에 대한 모니터링 권한과 제어 권한을 구분할 수 있다. 마지막으로 엑세스 리스트를 활용하여 접속 가능한 NMS 서버의 IP를 제한할 수도 있다.

 

 

3) 문제 풀이

 

라우터에 SNMP 에이전트 기능을 실행시켜 보자.

 

[출제유형 1 – SNMP 에이전트 설정]

구분

내용

토폴로지

출제유형

R1 SNMP를 활성화 시켜라. 이때 R1 SNMP를 이용해 TCP connection 정보를 1.1.1.254에게만 전달함을 허용한다. 커뮤니티는 ‘cisco’로 권한은 RO로 설정하라.

설명

TCP 커넥션 정보는 tty를 의미한다.

ⓑ 나머지는 문제의 정보를 그대로 설정하면 된다.

솔루션

[R1]

snmp-server community cisco RO

snmp-server enable traps tty

snmp-server host 1.1.1.254 cisco  tty

결과값

[R1]

R1#show snmp host

Notification host: 1.1.1.254  udp-port: 162   type: trap

user: cisco     security model: v1


 

 

10. Accounting

 

1) Concept

 

어카운팅(accounting)은 회계처럼 어떤 이벤트에 대한 횟수를 카운트하는 의미이다. 일반적으로 라우터에서는 특정 IP 패킷에 대한 모니터링을 위해 카운트(count)를 하기 위한 개념으로 사용되어 진다. 라우터에서 어카운팅을 설정할 때는 인바운드와 아웃바운드에서 사용되는 명령어가 조금 다르다. 인바운드 IP 패킷에 대한 모니터링에서는 ‘ip accounting-list’를 사용하고 반대로 아웃바운드 IP 패킷에 대한 모니터링에서는 ‘ip route-cache flow’ 기능을 사용한다.

 

 

2) 동작 원리

 

일반적으로 어카운트 리스트를 사용하면 특정 소스 어드레스에 대해 카운트를 할 수 있다. 특정 소스 어드레스를 어카운트 하기 위해서는 먼저 어카운팅 리스트(accounting-list)를 만들어 카운트를 원하는 소스 어드레스를 정의한다. 그후에 카운트 하기 원하는 인터페이스에서 아웃바운드 방향으로 설정해 준다. 참고로 IP 패킷에 대한 어카운팅을 할 경우에는 ‘accounting-list’ 에 정의된 소스 IP 어드레스만 카운트한다는 것에 유의하자.

 

 

3) 문제 풀이

 

어카운팅 리스트를 설정해서 특정 소스 IP 어드레시에 대해서 카운트를 해 보자.

 

[출제유형 1 – aaa 설정]

구분

내용

토폴로지

출제유형

R1에서 룹백0에서 사용하는 IP에 대해서 어카운팅을 하라. , 다른 모든 Source IP 어드레스에 대한 어카운팅은 disable 한다. (F0/0에서 설정하라)

설명

Accounting-list를 만들고 1.1.1.1에 대해서만 카운트하게 설정한다.

솔루션

[R1]

ip accounting-list 1.1.1.1 0.0.0.0

!

interface FastEthernet0/0

 ip accounting output-packets

결과값

[R1]

! 1.1.1.1에 대한 어카운팅 결과

R1#show ip accounting output-packets

   Source           Destination              Packets               Bytes

 

Accounting data age is 0

 

! 1.1.1.1 SIP로 사용하는 패킷 발생

R1#ping 1.1.2.2 source 1.1.1.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/60/136 ms

 

! 1.1.1.1에 대한 어카운팅 결과

R1#show ip accounting output-packets

   Source           Destination              Packets               Bytes

 

Accounting data age is 1


 

 

11. SLA

 

1) Concept

 

SLA‘Service Level Agreement’의 약자로 우리말로는 서비스 수준 협약서비스정도로 풀이된다. 조금 쉽게 풀어서 말하자면 고객에게 제공되는 서비스에 대한 품질 보장정도의 의미이다. 일반적으로 SLA에서는 가용성(availability), 지연율(latency), 패킷 로스(packet loss), 지터(jitter) 4가지를 척도로 사용한다. 가용성은 무중단 서비스를, 지연율은 서비스에 대한 요청후 시연될때까지의 소요 시간을 의미한다. 패킷 로스는 네트웍 통신에서 병목현상(bottleneck) 발생시 사용자 데이터에 대한 분실 가능성을, 지터는 보이스나 비디오 서비스시에 발생할 수 있는 가변적인 시간 지연현상을 의미한다.

 

 

2) 동작 원리

 

CCIE R&S 시험에서는 고객에게 제공될 서비스 수준을 특정하기 보다는 시스코 라우터와 스위치에서 IP 트래픽 모니터링을 통해 어플리케이션과 서비스를 분석하는 기능에 대한 설정이 요구된다. 라우터와 스위치의 SLA 기능을 사용하면 어플리케이션 수준의 트래픽에 대한 분석이 가능하다. 일반적으로 CCIE R&S 시험에서는 telnet 등의 세션에 대해 특정 라우터에서 분석이 가능하게 하라고 출제된다. 아래는 시스코 IOS별로 IP SLA 기능이 지원되는 각종 서비스에 대한 정리이다.

 

[ - IP SLA Operations Mapped to Cisco IOS Releases]

IP SLA Operations

Cisco IOS Software Releases

Echo

12.3(14)T

PathEcho

12.3(14)T

UDP Jitter

12.3(14)T

DNS

12.3(14)T

FTP

12.3(14)T

DHCP

12.3(14)T

UDP Echo

12.3(14)T

HTTP

12.3(14)T

TCP Connect

12.3(14)T

DLSw

12.3(14)T

RTP

12.4 (4)T

VoIP Gatekeeper Registration Delay

12.3(14)T

ICMP Jitter

12.4(6)T

VoIP Call Setup Post Dial Delay

12.3(14)T

※ 출처 : 시스코

 

 

3) 문제 풀이

 

두대의 라우터를 이용하여 IP SLA에 대해 문제를 풀어보자.

 

[출제유형 1 – IP SLA 설정]

구분

내용

토폴로지

출제유형

Telnet 세션에 대해 소스 어드레스가 R2 F0/0이고 데스티네이션 어드레스가 R1의 룹백0 인터페이스이다. R1에서 확인이 되어야 하고, 1시간마다 실행하고 life forever로 하며 설정을 마친후 바로 적용한다.

설명

IP SLA 기능을 이용한다.

frequency 1시간이므로 3600초로 설정한다.

start-time now로 설정한다.

솔루션

[R1]

Ip sla monitor responder

 

[R2]

ip sla monitor 10

 type tcpConnect dest-ipaddr 1.1.1.1 dest-port 23 source-ipaddr 1.1.12.2 source-port 54085

 frequency 3600

ip sla monitor schedule 10 life forever start-time now

결과값

[R1]

telnet 1.1.1.1

 

[R2]

R1#show ip sla monitor responder

IP SLA Monitor Responder is: Enabled

Number of control message received: 1 Number of errors: 0

Recent sources:

        1.1.12.2 [18:09:27.343 UTC Wed Feb 18 2009]

Recent error sources:

 
 

 

12. CORE-DUMP

 

1) Concept

 

앞서 확인한 SNMPSYSLOG 서버를 사용하는 방법과 TELNET이나 SSH를 활용하면 장비에 대한 모니터링이 가능하다. 그러나 이는 일반적으로 네트웍 장비가 정상 동작하는 경우에만 모니터링이 가능하다. 그래서 여기에서는 장비에 크래쉬등의 문제가 발생하였을 경우 장비 스스로 FTP등의 프로토콜을 사용하여 설정된 서버에 장애 관련 로그를 자동으로 전달하는 ‘DUMP’ 기능에 대해 알아보기로 하자.

 

 

2) 동작 원리

 

시스코사는 장비에서 발생하는 다양한 이슈에 대한 기술 지원을 위해 TAC(Technical Assitant Center)를 운영한다. TAC에서는 트러블 슈팅시에 일반적으로 시스템 장애시에 발생된 ‘CORE-DUMP’ 파일이나 ‘CRASHINFO’등을 분석한다. 라우터와 스위치에 DUMP 기능을 설정하면 장비 장애시에 스스로 CORE-DUMP 파일을 생성하여 지정된 서버에게 전달한다.

 

 

3) 문제 풀이

 

라우터에 CORE-DUMP 기능을 활성화 시켜 보자.

 

[출제유형 1 – SNMP 에이전트 설정]

구분

내용

토폴로지

출제유형

R1에서 발생할 크래쉬를 대비하여 CORE-DUMP 파일을 생성되게 하라. 크래쉬 발생시 FTP 서버에 core dump 파일이 남게 해야 한다. FTP 서버는 1.1.12.254라는 IP를 사용중이고 기타 정보는 아래와 같다.

- USERNAME : CCIE

- PASSWORD : CISCO

- Core File : R1-COREDUMP

설명

FTP 유저와 패스워드 생성시에 대문자임에 유의해야 한다.

ⓑ 파일명도 대문자임에 유의한다.

솔루션

[R1]

ip ftp username CCIE

ip ftp password CISCO

exception core-file R1-COREDUMP

exception protocol ftp

exception dump 1.1.12.254

결과값

[R1]

R1#show exception

1.1.12.254

 


 

13. Summer Time 설정

 

1) Concept

 

서머 타임이 시행될 경우에는 시즌이 시작되는 순간부터 1시간 정도 앞당겨 졌다가 시즌이 끝남과 동시에 시간이 다시 원복되어야 한다. 시즌이 시작되는 순간과 끝나는 순간에 관리자가 직접 네트웍 장비의 시간을 정확히 변경하기란 상당히 어렵다. 이 경우 라우터가 지원하는 서머타임 기능을 사용하면 상당히 간단하게 시간을 변경하고 원복할 수 있다.

 

 

2) 동작 원리

 

라우터나 스위치에 서머 타임(summer-time)을 설정하면 특정 시각에 시스템의 시간 정보가 자동적으로 변경되게 할 수 있다. 라우터에서는 서머 타임의 시작 시각과 종료 시각을 정의한 후에 타임존(time zone)을 정확히 기입만 해주면 된다. 라우터의 시각이 설정된 서머 타임의 범위에 들어가게 되면 즉각적으로 적용이 된다.

 

 

3) 문제 풀이

 

그럼 R1에서 서머 타임을 설정해 보자.

 

[출제유형 1 – 서머 타임 설정]

구분

내용

토폴로지

출제유형

4월 두번째 일요일 오전 2시에 시작해서 10월 두번째 일요일 오전 2시에 끝나는 서머 타임을 R1에 설정하시오. 타임존은 퍼시픽 시간을 이용하여야 한다.

설명

ⓐ 서머 타임 기능을 이용한다.

솔루션

[R1]

clock summer-time PST recurring 2 sun mar 02:00 2 sun oct 02:00

clock timezone PST -8

결과값

[R1]

R1#show clock detail

11:36:36.851 PST Wed Feb 18 2009

Time source is NTP

Summer time starts 02:00:00 PST Sun Mar 8 2009

Summer time ends 02:00:00 PST Sun Oct 11 2009

 

 

 

- IV. IP and IOS Feature 완료 -

 

 

[copy right by CrazyWoo(우명하); woomha@naver.com]


Title
List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 How To Install GNS3 on Ubuntu 10.04 LTS Hojung 2011.04.25 6227
50 Cisco SPAN Hojung 2013.04.17 2217
49 f/r setting on main interface Hojung 2011.05.03 2295
48 Reset configuration in router/switch Hojung 2011.05.03 2618
47 Basic Configuration (password, domain-lookup, hostname, timeout) Hojung 2011.05.03 3077
46 [Crazy4CCIE-R&S편]VII.Security Hojung 2011.04.27 5133
45 [Crazy4CCIE-R&S편]VI. IP QoS (완료) Hojung 2011.04.27 9218
44 [Crazy4CCIE-R&S편]V.IP Multicast (완료) Hojung 2011.04.27 8865
43 [Crazy4CCIE R&S편]번외편 - 다이나밉스 운영 환경 최적화 Hojung 2011.04.27 5087
» [Crazy4CCIE-R&S편]IV.IP and IOS Feature (완료) Hojung 2011.04.27 6348
41 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(3)-OSPFv3) Hojung 2011.04.27 4860
40 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(2)-RIPng) Hojung 2011.04.27 3530
39 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(1)-Concept) Hojung 2011.04.27 3343
38 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(3)-Red&Filter) Hojung 2011.04.27 2910
37 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(2)-Red&Metric) Hojung 2011.04.27 5059
36 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(1)-Concept) Hojung 2011.04.27 7074
35 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(3)-distribute-list-설정) Hojung 2011.04.27 3793
34 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(2)-labconfig) Hojung 2011.04.27 2620
33 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(1)-concept Hojung 2011.04.27 2486
32 [Crazy4CCIE-R&S편]II.IGP(6-Filtering-(1~5)access-list&prefix-list Hojung 2011.04.27 4046
31 [Crazy4CCIE-R&S편]II.IGP(5-EIGRP-(5)-Authentication) Hojung 2011.04.27 2885
Board Pagination ‹ Prev 1 2 3 Next ›
/ 3

Designed by sketchbooks.co.kr / sketchbook5 board skin

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5