본문 바로가기
조회 수 2474 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print

http://cafe.naver.com/neteg/60409


3) 재분배시 라우트 필터 설정

 

이번에는 재분배시에 라우트 필터를 설정해 보겠다. 앞서 배운 디스트리뷰트 리스트가 동일한 라우팅 프로토콜간의 필터링이었다면, 여기서는 상이한 라우팅 프로토콜간의 재분배시에 발생하는 라우트 업데이트에 대한 필터링을 다룬다. 재분배시의 라우트 필터링 방법은 다음과 같다.

 

[재분배시 라우트 필터링 방법]

ⓐ 재분배 + 루트맵 + 스텐다드 엑세스 리스트<?xml:namespace prefix = o />

ⓑ 재분배 + 루트맵 + 익스텐디드 엑세스 리스트

ⓒ 재분배 + 루트맵 + 프리픽스 리스트

ⓓ 재분배 + 루트맵 + 태그

ⓔ 재분배 + 루트맵 + NULL0

ⓕ 재분배 + 라우트 타입

ⓖ 재분배 + 디스트리뷰트 리스트 + @

 

모든 라우팅 프로토콜로의 재분배시에 위의 경우의 수를 모두 설명하기는 어렵다. 그러므로 아래 토폴로지를 바탕으로 상황별로 가장 적합한 라우팅 프로토콜간의 재분배와 이에 대한 필터링을 설명하기로 하겠다.

 

[그림 재분배 랩]

 

 

 


① 재분배 + 루트맵 + 스텐다드 엑세스 리스트

 

가장 기본적이면서도 일반적인 경우이다. 여기서는 R1에서 RIP OSPF로 재분배하고, 이때 199.172.0.0/16에 포함된 네트웍들만 재분배를 하도록 해보자. 재분배시의 기본 메트릭 타입은 라우터 경유시에 코스트가 변하는 E1로 설정하도록 하자.

 

[재분배 + 루트맵 + 스텐다드 엑세스 리스트 설정]

구분

명령어

R1

access-list 99 permit 199.172.0.0 0.0.255.255

!

route-map MAP99

 match ip address 99

!

router ospf 1

 redistribute rip subnets metric-type 1 route-map MAP99

 

R2 OSPF 라우팅 테이블을 확인해 보도록 하자.

 

[– R2 OSPF 라우팅 테이블]

구분

명령어

R1

R2#show ip route ospf

O E1 199.172.11.0/24 [110/84] via 1.1.12.1, <?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 />00:23:42, Serial1/0

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:23:42, Serial1/0

O E1 199.172.10.0/24 [110/84] via 1.1.12.1, 00:23:42, Serial1/0

(이하 생략)

 


② 재분배 + 루트맵 + 익스텐디드 엑세스 리스트

 

BB1에서 수신한 RIP 테이블중에 199.172.0.0/16 150.100.1.0/16에 포함된 서브넷 중에프리픽스가 24bit인 네트웍만 OSPF로 재분배하도록 해보자. 이번에는 네임드 익스텐디드 엑세스 리스트와 루트맵을 사용해 보도록 하자.

 

[재분배 + 루트맵 + 익스텐디드 엑세스 리스트 설정]

구분

명령어

R1

ip access-list extended NAMED-EXT-ACL

 permit ip 199.172.0.0 0.0.255.255 host 255.255.255.0

permit ip 150.100.0.0 0.0.255.255 host 255.255.255.0

!

route-map MAP-EXT-ACL

 match ip address NAMED-EXT-ACL

!

router ospf 1

 redistribute rip subnets metric-type 1 route-map MAP-EXT-ACL

 

재분배시 라우트 필터링을 위해 익스텐디드 엑세스 리스트를 사용하면 프리픽스 리스트처럼 특정 프리픽스에 대한 필터링이 가능해진다. 위의 문구에서도 알 수 있듯이 엑세스 리스트 구문의 소스 IP 부분만이 매칭될 라우팅 테이블로 정의되고, 뒤의 데스티네이션 IP 부분의 ‘host’ 명령어 뒷단의 서브넷이 매칭될 프리픽스로 정의된다. 이제 R2 OSPF 라우팅 테이블을 확인해 보도록 하자.

 

[– R2 OSPF 라우팅 테이블]

구분

명령어

R1

R2#show ip route ospf

O E1 199.172.11.0/24 [110/84] via 1.1.12.1, 00:00:02, Serial1/0

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:32:16, Serial1/0

150.100.0.0/24 is subnetted, 1 subnets

O E1    150.100.1.0 [110/84] via 1.1.12.1, 00:00:02, Serial1/0

(이하 생략)

 


③ 재분배 + 루트맵 + 프리픽스 리스트

 

이번에는 프리픽스 리스트를 이용한 필터링을 적용해 보자. 프리픽스 리스트를 사용하면 특정 IP, 특정 프리픽스 그리고 서브넷 범위 단위의 필터링이 모두 가능하다. RIP의 네트웍 중에 199.172.0.0/16에 포함된 서브넷은 모두 OSPF로 재분배해보자. 다만 150.100.1.0/24 24bit만 허용해 보자. 이 모든 작업을 프리픽스 리스트와 루트맵을 사용해서 하도록 한다.

 

[재분배 + 루트맵 + 프리픽스 리스트 설정]

구분

명령어

R1

ip prefix-list PREFIX-RIP seq 10 permit 199.172.0.0/16 le 32

ip prefix-list PREFIX-RIP seq 20 permit 150.100.1.0/24

!

route-map MAP-RIP

 match ip address prefix RPEFIX-RIP

!

router ospf 1

 redistribute rip subnets metric-type 1 route-map MAP-RIP

 

이제 R2 OSPF 라우팅 테이블을 확인해 보면 원하는 결과를 확인할 수 있을 것이다.

 

[– R2 OSPF 라우팅 테이블]

구분

명령어

R1

R2#show ip route ospf

O E1 199.172.11.0/24 [110/84] via 1.1.12.1, 00:00:02, Serial1/0

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:32:16, Serial1/0

150.100.0.0/24 is subnetted, 1 subnets

O E1    150.100.1.0 [110/84] via 1.1.12.1, 00:00:02, Serial1/0

(이하 생략)

 


④ 재분배 + 루트맵 + 태그

 

이번에는 태그(tag)를 이용한 필터링을 적용해 보자. 일상 생활에서 태그란 말 그대로 물건에 딸려오는 꼬리표로서 물건에 대한 설명이나 식별자의 역할을 한다. 라우팅 프로토콜도 마찬가지로서 태그가 설정된 라우팅 테이블은 태그를 활용하여 필터링이 가능하다. 기본적으로 라우팅 테이블에는 태그가 설정되지 않으므로 태그로 필터링을 하려면 재분배를 하기 이전에 해당 라우팅 테이블에 태그를 설정해 주어야 한다.

 

태그를 설정할 수 있는 방법은 여러가지 이다. 루트맵을 사용하여 특정 네트웍에 태그를 설정하는 방법과 라우트 서머리(summary)를 할 때 옵션으로 태그를 붙이는 방법이다.

 

[태그 설정 방법]

구분

명령어

R1

! 루트맵을 활용하여 태그 설정

ip prefix-list PREFIX-TAG seq 10 permit 199.172.0.0/16 le 32

!

route-map MAP-TAG permit 10

match ip address prefix PREFIX-TAG

set tag 10

R1

! 라우트 서머리를 하면서 옵션으로 태그 설정

router ospf 1

 summary-address 199.172.0.0 255.255.0.0 tag 10

 

루트맵을 활용할 경우 라우팅 테이블을 확인하면 아래와 같다.

 

[– R2의 태그 확인]

구분

명령어

R2

R2#show ip route 199.172.1.0

Routing entry for 199.172.1.0/24

  Known via "ospf 1", distance 110, metric 84

  Tag 10, type extern 1

  Last update from 1.1.12.1 on Serial1/0, 00:00:16 ago

  Routing Descriptor Blocks:

  * 1.1.12.1, from 1.1.1.1, 00:00:16 ago, via Serial1/0

      Route metric is 84, traffic share count is 1

      Route tag 10

 

그럼 이번에는 R1 OSPF에서 199.172.0.0/16에 포함된 네트웍들을 16bit로 서버리를 한 다음에 태그를 10으로 설정해 보자. 그 후에 R2에서 OSPF EIGRP YY로 재분배 할 때 태그를 활용하여 199.172.0.0/16는 전달하고 나머지 네트웍들을 모두 필터링 해 보도록 하자.

 

[재분배 + 루트맵 + 태그(+서머리) 설정]

구분

명령어

R1

router ospf 1

 summary-address 199.172.0.0 255.255.0.0 tag 10

R2

route-map MAP-TAG permit 10

match tag 10

!

router eigrp 1

 redistribute ospf 1 metric 1544 2000 255 1 1500 route-map MAP-TAG

 

이제 R1, R2 그리고 R3의 라우팅 테이블을 확인 보자.

 

[– R2 OSPF 라우팅 테이블]

구분

명령어

R1

R1#show ip route

(생략)

     150.100.0.0/24 is subnetted, 1 subnets

R       150.100.1.0 [120/1] via 150.1.1.254, 00:00:10, FastEthernet0/0

     150.1.0.0/24 is subnetted, 1 subnets

C       150.1.1.0 is directly connected, FastEthernet0/0

R    199.172.4.0/24 [120/1] via 150.1.1.254, 00:00:10, FastEthernet0/0

O    199.172.0.0/16 is a summary, 00:03:00, Null0

R2

R2#show ip route ospf

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:04:30, Serial1/0

     150.100.0.0/24 is subnetted, 1 subnets

O E1    150.100.1.0 [110/84] via 1.1.12.1, 00:03:58, Serial1/0

     150.1.0.0/24 is subnetted, 1 subnets

O E1    150.1.1.0 [110/84] via 1.1.12.1, 00:03:58, Serial1/0

O E1 199.172.0.0/16 [110/84] via 1.1.12.1, 00:03:48, Serial1/0

R3

R3#show ip route eigrp 1

D EX 199.172.0.0/16 [170/2681856] via 1.1.23.2, 00:02:26, Serial1/1

 

R1에서는 당연히 BB1으로부터 수신한 199.172.0.0/16 네트웍에 포함된 24bit들과 150.100.1.0/24가 보인다. 또한 OSPF에서 서머리한 199.172.0.0/16 정보도 보인다. 현재 199.172.0.0/16에만 태그가 10으로 설정되어 있다. R2에서는 150.100.1.0/24는 그대로 보이지만, 199.172.0.0/16 네트웍은 16bit만 보이고 상세한 24bit 정보들은 모두 서프레스(suppress)되어 보이지 않는다.

 

R2 R1에게 수신한 BB1의 정보를 R3에게 재분배할때는 태그 10이 설정된 정보만 전달하고 있다. R2의 설정을 보면 ‘route-map MAP-TAG permit 10’ 하단에서 ‘match tag 10’을 사용하여 태그가 10인 라우팅 테이블만 매치시키고 있다. ‘route-map MAP-TAG permit 20’ 구문이 없으므로 나머지는 라우팅 테이블은 모두 묵시적으로 ‘deny all’로 동작한다. 이런 사유로 R3 EIGRP YY의 라우팅 테이블에는 199.172.0.0/16 정보만 보이게 되는 것이다.

 

 


⑤ 재분배 + 루트맵 + NULL0

 

지금까지 단방향 재분배를 하는 경우에는 이슈가 없지만, 양방향 재분배를 하는 경우에는 라우트 루핑이 발생한다. 예를 들어 R1 RIP를 통해 199.172.1.0/24 부터 199.172.16.0/24까지 16개의 24bit 수신하였다고 가정하자. 그리고 R1의 위의 라우팅 테이블을 OSPF로 재분배하고, 다시 OSPF에서는 199.172.0.0/16로 서머리 한다.

 

일단 라우팅 테이블에 대한 서머리를 하게 되면, 라우팅 테이블에서 ‘NULL0’라는 가상의 인터페이스가 생성된다. 이때 OSPF를 다시 RIP으로 재분배 한다면, RIP 199.172.0.0/16 네트웍이 OSPF에 있다고 착각하고 이를 받아 들인다. 이것이 바로 라우트 루핑이다.

 

[상호(mutual) 재분배]

구분

명령어

R1

router ospf 1

redistribute rip subnets

summary-address 199.172.0.0 255.255.0.0

!

router rip

redistribute ospf metric 1

 

이를 방지하기 위해서는 OSPF에서 RIP으로 재분배 할 경우, 199.172.0.0/16 정보에 대한 필터링이 필요하다. 이를 위해서는 OSPF RIP으로 재분배할 때 아래처럼 엑세스 리스트나 프리픽스 리스트를 만들어 199.172.0.0/16만을 필터링 하면 된다.

 

[상호 재분배시 루핑 방지를 위해 서머리된 경로 필터링]

구분

명령어

R1

ip prefix-list PREFIX-199 seq 10 permit 199.172.0.0/16

!

route-map MAP-199 deny 10

 match ip address prefix RPEFIX-199

route-map MAP-199 permit 20

!

router rip

 redistribute ospf 1 metric 1 route-map MAP-199

 

위의 경우 ‘route-map’ 첫 항목은 199.172.0.0/16을 수신하지 않기 위해 ‘deny 10’으로 설정되어 있다. 이외의 경로는 ‘permit 20’ 구문에 해당되므로 정상적으로 수신한다. 그러나 이보다 조금 더 쉬운 방법은 NULL0 인터페이스를 필터링 하는 방법이다. NULL0는 라우트 서머리때 생성되는 가상의 인터페이스인데, ‘show ip route’에서 확인이 가능하다. NULL0를 활용하면 엑세스 리스트나 프리픽스 리스트 없이 바로 루트맵 만으로 설정이 가능하다. 경우에 따라 다르지만 일반적으로 CCIE R&S 시험에서는 NULL0 필터링 방법이 더 권장되는 쉬운 방법이다.

 

[상호 재분배시 루핑 방지를 위해 NULL0 필터링]

구분

명령어

R1

route-map MAP-NULL0 deny 10

 match interface null0

route-map MAP-NULL0 permit 20

!

router rip

 redistribute ospf 1 metric 1 route-map MAP-NULL0

 


⑥ 재분배 + 라우트 타입

 

라우트 타입이란 OSPF IS-IS에서 언급되는 인터널 경로 또는 익스터널 경로 등을 의미한다. 여기서는 OSPF의 익스터널 경로인 E1 E2를 가지고 설명해 보겠다. OSPF의 경우에는 재분배시에 메트릭 타입을 E1 또는 E2로 설정할 수 있다.

 

만약에 BB1 R1에게 던져준 네트웍들은 OSPF로 재분배할 경우 외부 경로가 되므로 E1 또는 E2로 재분배하게 된다. 기존에 OSPF가 가진 경로들은 인트라 경로인 ‘O’와 인터널 경로인 ‘O IA’일 것이다. OSPF RIP 정보를 수신한 후에, 다시 OSPF 정보를 EIGRP YY로 재분배 한다면 R2 R3 EIGRP YY BB1이 던져준 RIP 정보들도 보유하게 된다. 만약에 OSPF EIGRP YY로 재분배할 때 RIP이 던져준 익스터널 정보만 배재하고 나머지 라우팅 정보만 전달하려면 어떻게 해야 할까?

 

앞서 학습한 것처럼 태그를 사용하는 것도 한가지 방법이다. 그외의 방법으로 재분배 된 경로들만이 가지는 공통된 특징을 가지고 필터링을 적용하면 된다.

 

[재분배 + 루트맵 + 라우트 필터 설정]

구분

명령어

R1

router ospf 1

 redistribute rip subnets metric-type 2

R2

route-map MAP-RTYPE deny 10

match route-type external type-2

route-map MAP-RTYPE permit 20

!

router eigrp 1

 redistribute ospf 1 metric 1544 2000 255 1 1500 route-map MAP-RTYPE

 

OSPF 외부에서 OSPF 내부로 재분배된 경로는 공통적으로 E1 또는 E2의 형태를 취한다. 일반적으로 기본값이 E2이므로, R2에서 OSPF EIGRP YY로 재분배할 때 라우트 타입(route-type)이 익스터널이고 값이 2인 라우팅 테이블만 필터링을 설정하고 나머지는 허용하면 된다.

 

재분배 + 디스트리뷰트 리스트 + @

 

라우트 업데이트에 대한 필터링은 기본적으로 디스트리뷰트 리스트(distribute-list)를 사용한다. 재분배시에 필터링이 필요하면 앞서에서 살펴본 것처럼 일반적으로 루트맵과 연계해서 사용한다. 그러나 재분배를 먼저 선언해 놓은 상태라면 디스트리뷰트 리스트를 사용하여  상이한 라우팅 프로세스 간의 필터링이 가능하다.

 

그러나 기억해야 할 점이 한가지 있다. 라우팅 프로세스내에서의 디스트리뷰트 리스트의 사용은 인바운드와 아웃바운드 설정이 모두 가능하다. 그러나 재분배를 통한 라우팅 프로세스 간에 필터링을 위한 디스트리뷰트 리스트는 항상 인바운드만 가능하다. 기억해야 할 것은 인바운드로 설정함에도 불구하고 라우터 명령어상에서는 항상 ‘out’으로 설정해야만 한다.

 

그럼 R1 RIP 정보중에 150.100.1.0/24 OSPF로 재분배를 해 보자.

 

[– EIGRP 100 EIGRP YY로 재분배]

구분

명령어

R1

access-list 15 permit 150.100.1.0 0.0.0.255

!

router ospf 1

distribute-list 15 out rip

 

OSPF에서 RIP의 정보를 재분배해서 받아올 때 필터링을 적용하므로 방향은 원래 인바운드이다. 그러나 앞서 설명했듯이 디스트리뷰트 리스트를 상이한 라우팅 프로토콜간의 재분배시에 사용한다면 방향은 인바운드임에도 불구하고 명령어는 항상 ‘out’으로만 설정이 가능하다.

 

[– EIGRP 100 EIGRP YY로 재분배]

구분

명령어

R2

R2#show ip route ospf

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:12:09, Serial1/0

     150.100.0.0/24 is subnetted, 1 subnets

O E2    150.100.1.0 [110/20] via 1.1.12.1, 00:12:07, Serial1/0

 

위에서는 엑세스 리스트를 사용했지만, 디스트리뷰트 리스트 자체가 엑세스 리스트와 프리픽스 리스트를 모두 지원하므로 어느것을 사용하던지 관계없다. 다만 일반적으로 재분배시의 필터링은 디스트리뷰트 리스트 보다는 루트맵을 사용하는 편이 조금 더 편할 것이다.

 

 

 

- Redistribute(재분배) 최종회 -

 

 

 

[copy right by CrazyWoo(우명하); woomha@naver.com]


Title
List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 How To Install GNS3 on Ubuntu 10.04 LTS Hojung 2011.04.25 5598
50 Cisco SPAN Hojung 2013.04.17 1849
49 f/r setting on main interface Hojung 2011.05.03 1964
48 Reset configuration in router/switch Hojung 2011.05.03 2182
47 Basic Configuration (password, domain-lookup, hostname, timeout) Hojung 2011.05.03 2727
46 [Crazy4CCIE-R&S편]VII.Security Hojung 2011.04.27 4544
45 [Crazy4CCIE-R&S편]VI. IP QoS (완료) Hojung 2011.04.27 8190
44 [Crazy4CCIE-R&S편]V.IP Multicast (완료) Hojung 2011.04.27 7584
43 [Crazy4CCIE R&S편]번외편 - 다이나밉스 운영 환경 최적화 Hojung 2011.04.27 4632
42 [Crazy4CCIE-R&S편]IV.IP and IOS Feature (완료) Hojung 2011.04.27 5760
41 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(3)-OSPFv3) Hojung 2011.04.27 4348
40 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(2)-RIPng) Hojung 2011.04.27 3068
39 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(1)-Concept) Hojung 2011.04.27 2934
» [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(3)-Red&Filter) Hojung 2011.04.27 2474
37 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(2)-Red&Metric) Hojung 2011.04.27 4540
36 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(1)-Concept) Hojung 2011.04.27 6385
35 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(3)-distribute-list-설정) Hojung 2011.04.27 3262
34 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(2)-labconfig) Hojung 2011.04.27 2197
33 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(1)-concept Hojung 2011.04.27 2056
32 [Crazy4CCIE-R&S편]II.IGP(6-Filtering-(1~5)access-list&prefix-list Hojung 2011.04.27 3468
31 [Crazy4CCIE-R&S편]II.IGP(5-EIGRP-(5)-Authentication) Hojung 2011.04.27 2469
Board Pagination ‹ Prev 1 2 3 Next ›
/ 3

Designed by sketchbooks.co.kr / sketchbook5 board skin

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5