본문 바로가기
조회 수 4517 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print

http://cafe.naver.com/neteg/60408


2) 재분배시 메트릭 설정

 

단방향 재분배는 재분배에 있어 가장 간단한 방법이며 보편적으로 사용되는 기술이다. 일반적으로 단방향 재분배시에는 해당 라우팅 프로토콜에 적합한 타입으로의 메트릭 변경과 라우트 필터 적용에 대한 고려가 이루어져야 한다. 이번 장에서는 모든 라우팅 프로토콜별로 단방향으로 재분배하는 방법을 확실하게 학습하고 넘어가도록 하자.

 

[스태틱 라우팅의 재분배]

참고로 CCIE R&S 시험에서는 특별한 경우가 아니라면 STATIC 라우팅을 사용할 수 없으므로 이 경우는 여기서 간단한 설정만 해보도록 한다.

<?xml:namespace prefix = o /> 

재분배에 대한 이해를 돕기 위한 실습 토폴로지는 이전의 디스트리뷰트 리스트에서 사용한 랩을 그대로 사용하도록 한다.

 

[그림 재분배 랩]

 

OSPF로의 재분배

 

OSPF로의 재분배란 다른 라우팅 프로토콜이 가진 라우팅 테이블 정보를 OSPF로 전달해 주는 것이다. 영어로 사용하자면 ‘from A to OSPF’이므로 모든 설정은 OSPF 프로세서 내에서 이루어진다. 이번에는 각 라우팅 프로토콜별로 명령어를 확인해 보자. 기억해야 할 점은 OSPF는 다른 라우팅 프로토콜과는 달리 특정 IP뿐만 아니라 그 IP가 사용하는 서브넷 마스크에 포함된 네트웍까지 재분배해야 한다는 것이다.

 

[ - OSPF로의 재분배]

구분

명령어

from RIP

to OSPF

router ospf 1

 redistribute rip subnets [metric-type] [E1|E2] [route-map NAME]

from EIGRP to OSPF

router ospf 1

 redistribute eigrp 1 subnets [metric-type] [E1|E2] [route-map NAME]

<?xml:namespace prefix = st1 />Conn

to OSPF

router ospf 1

 redistribute connected subnets [metric-type] [E1|E2] [route-map NAME]

from Static

to OSPF

router ospf 1

 redistribute static subnets [metric-type] [E1|E2] [route-map NAME]

 

from RIP to OSPF

 

RIP OSPF로 재분배하는 경우를 확인해 보자. 그림에서 R1에서 RIP OSPF가 운영되고 있으므로 R1에서 설정해야 한다. RIP에서 사용하는 메트릭 즉, HOP OSPF에서 아무런 의미가 없다. 그러므로 RIPOSPF로 재분배할 때는 메트릭 타입을 E1또는 E2로 적절히 변경하여 설정할 수 있으며, 기본값은 E2이다. E1 E2의 차이점은, E2의 경우 OSPF 영역에서 라우터를 경유하더라도 최초 재분배시 적용된 메트릭 값이 변치 않는다. E1은 반대로 라우터 경우시 계속 누적되면서 변하는 경우이다.

 

[– RIP OSPF로 재분배]

구분

명령어

R1

! RIP의 전체 라우팅 테이블을 OSPF로 재분배 (메트릭은 기본값인 E2)

router ospf 1

 redistribute rip subnets

R1

! RIP의 라우팅 테이블이 OSPF 라우터를 지나면 메트릭이 변하는 경우

router ospf 1

 redistribute rip subnets metric-type 1

 

from EIGRP YY to OSPF

 

이번에는 EIGRP YY OSPF로 재분배하는 경우를 확인해 보자. 그림에서 R2에서 OSPF EIGRY YY가 운영되고 있으므로 R2에서 설정해야 한다.

 

[– EIGRP YY OSPF로 재분배]

구분

명령어

R2

! EIGRP YY의 전체 라우팅 테이블을 OSPF로 재분배 (메트릭은 기본값인 E2)

router ospf 1

 redistribute eigrp 1 subnets

R2

! EIGRY YY의 라우팅 테이블이 OSPF 라우터를 지나면 메트릭이 변하는 경우

router ospf 1

 redistribute eigrp 1 subnets metric-type 1

 

from Connected to OSPF

 

이번에는 R2에서 ‘connected’ 인터페이스들을 OSPF로 재분배 하도록 한다. 먼저 R2가 가진 전체 인터페이스의 IP OSPF로 재분배하는 방법과, F0/0만 재분배하는 방법을 확인해 보자.

 

[– Connected 인터페이스의 IP OSPF로 재분배]

구분

명령어

R2

! R2의 전체 인터페이스의 IP를 재분배하는 방법

router ospf 1

 redistribute connected subnets

R2

! R2 F0/0 IP만을 재분배하는 방법

route-map MAP-CONNECTED permit 10

 match interface f0/0

!

router ospf 1

 redistribute connected subnets route-map MAP-CONNECTED

 

특정 인터페이스의 IP만을 재분배 할 경우에는 먼저 루트맵(route-map)을 만든후에 그 인터페이스만 매치시키면 된다.

 

from STATIC to OSPF

 

사실 CCIE R&S 시험에서는 출제될 가능성이 거의 없지만, 실무에서는 많이 쓰이는 STATIC OSPF로 재분배하는 방법을 학습해 보자. 여기서는 실습을 위해 R2에서 스태틱 라우트로 197.68.1.0/24 197.68.2.0/24에 대한 넥스트 홉을 BB2 F0/0 IP로 설정해 본 후에 OSPF로 재분배 하도록 한다.

 

[– EIGRP YY OSPF로 재분배]

구분

명령어

R2

! R2의 전체 스태틱 라우트를 OSPF로 재분배하는 방법

ip route 197.68.1.0 255.255.255.0 150.2.1.254

ip route 197.68.2.0 255.255.255.0 150.2.1.254

!

router ospf 1

 redistribute static subnets

R1

! R2의 특정 스태틱 라우트(197.68.1.0/24)만을 OSPF로 재분배하는 방법

ip route 197.68.1.0 255.255.255.0 150.2.1.254

ip route 197.68.2.0 255.255.255.0 150.2.1.254

!

access-list 1 permit 197.68.1.0 0.0.0.255

!

route-map MAP-STATIC permit 10

 match ip address 1

!

router ospf 1

 redistribute static subnets route-map MAP-STATIC

 

스태틱 라우트에 대한 재분배는 모든 라우팅 프로토콜에서 명령어가 동일하다. 스태틱 라우트에 대한 IGP로의 재분배는 CCIE R&S의 다루지 않으므로 향후에는 더 이상 언급하지 않기로 한다.


RIP로의 재분배

 

RIP에서는 메트릭으로 홉을 사용한다. 그러므로 타 라우팅 프로토콜을 RIP으로 재분배한다면 해당 라우터에서 기본적으로 메트릭을 1 이상의 임의의 값으로 설정해 주어야 한다. 그러나 Connected 인터페이스를 재분배할 경우에는 굳이 메트릭을 기재하지 않아도 기본값인 1로 설정된다. OSPF와는 달리 RIP EIGRP는 재분배시에 기본적으로 서브넷에 대한 설정은 하지 않아도 된다.

 

[ - RIP로의 재분배]

구분

명령어

from OSPF

to RIP

router rip

 redistribute ospf # metric value [route-map NAME]

from EIGRP to RIP

router rip

redistribute eigrp # metric value [route-map NAME]

from Conn

to OSPF

router rip

redistribute connected [metric value] [route-map NAME]

 

from OSPF to RIP

 

OSPFRIP으로 재분배하는 경우를 확인해 보자. RIP의 기능이나 메트릭 자체가 단순하므로 설정도 상당히 단순하다. CCIE R&S 시험에서 재분배시에 RIP의 메트릭에 대한 언급이 없다면 아무 숫자나 입력하면 된다. 그러나 R1 OSPF 테이블이 BB1에서 메트릭 3으로 보여야 된다는 식으로 축제된다면 재분배시에 메트릭을 3으로 설정해야만 한다.

 

참고로 RIP으로의 재분배에 있어 반드시 기억해야 할 중요한 포인트는 재분배시에 주어지는 메트릭의 값에 관계없이 해당 라우터에 직접 연결된 인터페이스(directed connected)는 주어지는 메트릭의 값에 관계없이 무조건 1로 상대방 라우터에게 재분배된다. 이 부분은 오프셋 리스트(off-set)를 활용하여 메트릭의 차이값만큼 추가해 주어야만 한다.

 

[– OSPF RIP으로 재분배]

구분

명령어

R1

! OSPF의 전체 라우팅 테이블을 RIP으로 재분배

router rip

 redistribute ospf 1 metric 1

R1

! OSPF의 라우팅 테이블을 RIP으로 재분배 하면서 메트릭을 3으로 설정

router rip

 redistribute ospf 1 metric 3

또는

router rip

 redistribute ospf 1 metric 1

 offset-list 0 in 2 s1/0

 

from EIGRP YY to RIP

 

이번에는 EIGRP YYRIP으로 재분배하는 경우를 확인해 보자. OSPF를 재분배하는 경우와 거의 동일하다. R1 R3 F0/1 EIGRP YY가 연동되고 있다고 가정하자.

 

[– EIGRP YY RIP으로 재분배]

구분

명령어

R1

! EIGRP YY의 전체 라우팅 테이블을 RIP으로 재분배

router rip

 redistribute eigrp 1 metric 1

R1

! EIGRP YY의 라우팅 테이블을 RIP으로 재분배 하면서 메트릭을 3으로 설정

router rip

 redistribute eigrp 1 metric 3

또는

router rip

 redistribute eigrp 1 metric 1

 offset-list 0 in 2 f0/1

 

from Connected to RIP

 

이번에는 R1에서 ‘connected’ 인터페이스들을 RIP으로 재분배 하도록 한다. 이번에도 R1이 가진 전체 인터페이스의 IP OSPF로 재분배하는 방법과, Serial 0 인터페이스만 재분배하는 방법을 확인해 보자.

 

[– Connected 인터페이스의 IP OSPF로 재분배]

구분

명령어

R1

! R1의 전체 인터페이스의 IP를 재분배하는 방법

router rip

 redistribute connected

R1

! R1 S1/0 IP만을 재분배하는 방법

route-map MAP-CONNECTED permit 10

 match interface s1/0

!

router rip

 redistribute connected route-map MAP-CONNECTED

 

특정 인터페이스의 IP만을 재분배 할 경우에는 먼저 루트맵(route-map)을 만든후에 그 인터페이스만 매치시키면 된다. 앞서 언급한 것 처럼 스태틱 라우트의 재분배는 이제 제외한다.


EIGRP로의 재분배

 

EIGRP편에서 언급한 것처럼 모든 IGP 중에 가장 복합적이면서도 복잡한 메트릭을 사용하는 것이 EIGRP이다. OSPF로 재분배시에는 메트릭 타입을, RIP으로의 재분배시에는 홉수만 기재하면 되지만, EIGRP로의 재분배는 BANDWIDTH, DELAY, RELIABILITY, LOAD, MTU 다섯 가지를 모두 고려해야 한다.

 

사실 그렇다고 해서 EIGRP로의 재분배가 엄청나게 복잡한 것은 아니다. 특별한 경우가 아닌 이상 CCIE R&S에서는 거의 기본값으로 재분배하기 때문에 이 기본값 수치만 기억하면 된다. 순서는 BANDWIDTH, DELAY, RELIABILITY, LOAD, MTU의 순이다. 한가지 더 기억해야 할 점은 CCIE R&S 시험에서는 EIGRP만이 유일하게 두개의 AS 형태로 출제된다. 그러므로 EIGRP YY EIGRP 100간의 재분배도 이루어지게 된다.

 

[ - RIP로의 재분배]

구분

명령어

from OSPF

to EIGRP

router eigrp 1

 redistribute ospf # metric 1544 2000 255 1 1500 [route-map NAME]

from RIP to EIGRP

router eigrp 1

redistribute rip metric 1544 2000 255 1 1500 [route-map NAME]

from Conn

to EIGRP

router eigrp 1

redistribute connected [metric 1544 2000 255 1 1500][route-map NAME]

from EIGRP to EIGRP

router eigrp 1

redistribute eigrp 100 [metric 1544 2000 255 1 1500] [route-map NAME]

 

from OSPF to EIGRP

 

OSPF EIGRP로 재분배하는 경우를 확인해 보자. 일반적으로 별다른 이슈 없이 메트릭 값들을 기본값으로 기재해 주면 된다.

 

[– OSPF EIGRP YY로 재분배]

구분

명령어

R2

router eigrp 1

 redistribute ospf 1 metric 1544 2000 255 1 1500

 

그런데 시험 문제에서 R2 loopback 0R3에서 보여야 하며, 이때 메트릭이 3,000,0004,000,000 사이의 값으로 보야야 한다면 어떻게 설정해야 할까? 먼저 위에서 메트릭을 기본값으로 재분배한 경우를 확인해 보자.

 

[– R3 라우팅 테이블]

구분

결과

R3

R3#show ip route eigrp

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

D EX    1.1.2.2/32 [170/2681856] via 1.1.23.2, 00:02:23, Serial1/1

 

메트릭이 현재 2,681,856’으로 보이고 있다. 가장 간단하게 메트릭을 변경시킬 수 있는 방법은 EIGRP의 주된 메트릭인 BANDWIDTH이므로 이를 더 작게 변경해 보면 된다. 물론 나머지 메트릭은 모두 기본값으로 두면 된다.

 

[– R2에서 EIGRP로 재분배시 메트릭 변경]

구분

명령어

R2

router eigrp 1

 redistribute ospf 1 metric 1000 2000 255 1 1500

 

결과를 확인하면 아래와 메트릭이 변경되어 있다.

 

[– R3 라우팅 테이블]

구분

결과

R3

R3#show ip route eigrp

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

D EX    1.1.2.2/32 [170/3584000] via 1.1.23.2, 00:01:13, Serial1/1

 

from RIP to EIGRP YY

 

이번에는 RIPEIGRP YY로 재분배하는 경우를 확인해 보자. 앞에서 메트릭 변경에 대해 언급하였으므로 단순히 재분배하는 방법만 확인하기로 한다.

 

[– RIP EIGRP YY로 재분배]

구분

명령어

R3

router eigrp 1

 redistribute rip metric 1544 2000 255 1 1500

 

from Connected to RIP

 

이번에도 R3에서 ‘connected’된 모든 인터페이스를 재분배 하는 방법과 특정 인터페이스만을 재분배하는 방법을 확인해 보자.

 

[– Connected 인터페이스의 IPEIGRP YY로 재분배]

구분

명령어

R3

! R3의 전체 인터페이스의 IP를 재분배하는 방법

router eigrp 1

 redistribute connected

R3

! R3loopback 0 IP만을 재분배하는 방법

route-map MAP-CONNECTED permit 10

 match interface loopback 0

!

router eigrp 1

 redistribute connected route-map MAP-CONNECTED

 

마찬가지로 특정 인터페이스의 IP만을 재분배 할 경우에는 먼저 루트맵(route-map)을 만든후에 그 인터페이스만 매치시키면 된다.

 

from EIGRP 100 to EIGRP YY

 

EIGRP는 다른 AS를 사용하는 EIGRP의 라우팅 테이블도 상호간에 재분배가 가능하다. OSPF도 다른 OSPF 프로세스를 상호간에 재분배가 가능하지만 일반적으로 멀티 OSPF 기능 자체가 권장되지는 않는다. CCIE R&S에서는 EIGRP YY EIGRP 100간의 재분배가 필요한 경우도 있다. EIGRP간의 재분배시에는 굳이 메트릭을 기재하지 않아도 무방하며, 시험에서도 메트릭에 대한 언급은 거의 하지 않는다.

 

[– EIGRP 100EIGRP YY로 재분배]

구분

명령어

R3

router eigrp 1

 redistribute eigrp 100

 

서브넷이나 메트릭을 기재할 필요가 없으므로 설정이 상당히 간단하다.

 

 

 

[copy right by CrazyWoo(우명하); woomha@naver.com]


Title
List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 How To Install GNS3 on Ubuntu 10.04 LTS Hojung 2011.04.25 5579
50 Cisco SPAN Hojung 2013.04.17 1836
49 f/r setting on main interface Hojung 2011.05.03 1955
48 Reset configuration in router/switch Hojung 2011.05.03 2160
47 Basic Configuration (password, domain-lookup, hostname, timeout) Hojung 2011.05.03 2714
46 [Crazy4CCIE-R&S편]VII.Security Hojung 2011.04.27 4487
45 [Crazy4CCIE-R&S편]VI. IP QoS (완료) Hojung 2011.04.27 8067
44 [Crazy4CCIE-R&S편]V.IP Multicast (완료) Hojung 2011.04.27 7424
43 [Crazy4CCIE R&S편]번외편 - 다이나밉스 운영 환경 최적화 Hojung 2011.04.27 4601
42 [Crazy4CCIE-R&S편]IV.IP and IOS Feature (완료) Hojung 2011.04.27 5693
41 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(3)-OSPFv3) Hojung 2011.04.27 4321
40 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(2)-RIPng) Hojung 2011.04.27 3042
39 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(1)-Concept) Hojung 2011.04.27 2915
38 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(3)-Red&Filter) Hojung 2011.04.27 2457
» [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(2)-Red&Metric) Hojung 2011.04.27 4517
36 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(1)-Concept) Hojung 2011.04.27 6312
35 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(3)-distribute-list-설정) Hojung 2011.04.27 3241
34 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(2)-labconfig) Hojung 2011.04.27 2179
33 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(1)-concept Hojung 2011.04.27 2032
32 [Crazy4CCIE-R&S편]II.IGP(6-Filtering-(1~5)access-list&prefix-list Hojung 2011.04.27 3435
31 [Crazy4CCIE-R&S편]II.IGP(5-EIGRP-(5)-Authentication) Hojung 2011.04.27 2457
Board Pagination ‹ Prev 1 2 3 Next ›
/ 3

Designed by sketchbooks.co.kr / sketchbook5 board skin

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5