본문 바로가기
조회 수 2556 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print
?

단축키

Prev이전 문서

Next다음 문서

+ - Up Down Comment Print

http://cafe.naver.com/neteg/60311


2) Lab Config

 

향후 진행될 실습을 위해 임의의 랩을 설정해 보자. 디스트리뷰트 리스트와 리디스트리뷰트의 실습을 위한 CCIE R&S 랩을 통해 아래의 토폴로지를 다음과 같이 구축하도록 한다.. 동일한 라우팅 프로토콜 내에서, 또는 상이한 라우팅 프로토콜간의 라우트 업데이트와 이에 대한 필터링을 위해 다음과 같이 OSPF, RIP, EIGRP YY, EIGRP 100, 그리고 BGP도 설정한다

<?xml:namespace prefix = o /> 

참고로 본 랩에서는 특별한 BGP 구성을 하지는 않으며, 단순히 IGP가 운영되지 않는 BB2와의 링크를 재분배 하는 수준에만 그치도록 하겠다. 현실적으로 수많은 BGP의 라우팅 테이블을 IGP로 재분배하는 경우는 없으며 CCIE R&S에서도 이러한 문제는 출제되지 않기 때문이다. 대신에 IGP가 없는 BB2와의 연결 인터페이스는 BGP 넥스트홉(next-hop) 이슈를 해결하기 위해 종종 재분배된다.

 

[그림 디스트리뷰트 리스트를 위한 CCIE R&S ]

 

 

 

FR 및 이더넷 설정

 

위의 논리적인 랩을 구현하기 위해 먼저 FR을 설정하도록 한다. R1 S0 DLCI 102, R2 S0 S1은 각각 201, 213으로 설정한다. R3 S1 312로 설정한다. 참고로 loopback 0 yy.yy.x.x/32의 형식으로 설정하도록 한다. R1 F0/0 150.1.YY.1/24, R2 F0/0 150.2.YY.1/24, 마지막으로 R3 F0/0 150.3.YY.1/24를 설정하도록 한다.

 

[라우터 프레임 릴레이 설정]

구분

명령어

R1

interface Serial1/0

 ip address 1.1.12.1 255.255.255.248

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay map ip 1.1.12.2 102 broadcast

 no frame-relay inverse-arp

R2

interface Serial1/0

 ip address 1.1.12.2 255.255.255.248

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay map ip 1.1.12.1 201 broadcast

 no frame-relay inverse-arp

!

interface Serial1/1

 ip address 1.1.23.2 255.255.255.248

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay map ip 1.1.23.3 213 broadcast

 no frame-relay inverse-arp

R3

interface Serial1/1

 ip address 1.1.23.3 255.255.255.248

 encapsulation frame-relay

 serial restart-delay 0

 frame-relay map ip 1.1.23.2 312 broadcast

 no frame-relay inverse-arp

 

 

 

② 스위치 설정

 

이번에는 스위치를 설정하도록 하자. BB1, BB2, BB3의 이더넷 포트는 물리적으로 SW1, SW2, SW3 F0/10에 각각 연동되어 있으므로 각각 VLAN을 설정하도록 하자. 다이나밉스의 경우는 BB들이 F0/10이 아닌 F0/0에 연동되어 있음을 기억하도록 하자.

 

스위치간 TRUNK/VTP/VLAN 설정 공식을 생각하며 순차적으로 설정해 보자. 먼저 첫 순서로 스위치간 TRUNK를 설정한다. SW4에 대한 사용은 필요없지만, TRUNK 포트인 F0/19부터 F0/24 포트까지 모드 RANGE 명령어를 사용하여 한번에 DOT1Q로 설정한다. 두번째로 VTP 통신을 위해 SW1 VTP 서버로 만들고 VTP_YY로 설정한다. 나머지 스위치를 VTP 클라이언트로 설정하겠다. 마지막으로 VLAN SW1에 만든후 VTP를 통해 전파한다.

 

 

 

ⓐ 스위치간 TRUNK 설정

 

[스위치 TRUNK 설정]

구분

명령어

SW1

! C3550 설정

conf t

 interface range f0/19 -24

 switchport trunk encapsulation dot1q

switchport mode trunk

 

! C3640 설정 (다이나밉스)

conf t

 interface range f0/9 -14

 switchport trunk encapsulation dot1q

switchport mode trunk

SW2

! C3550 설정

conf t

 interface range f0/19 -24

 switchport trunk encapsulation dot1q

switchport mode trunk

 

! C3640 설정 (다이나밉스)

conf t

 interface range f0/9 -14

 switchport trunk encapsulation dot1q

switchport mode trunk

SW3

! C3550 설정

conf t

 interface range f0/19 -24

 switchport trunk encapsulation dot1q

switchport mode trunk

 

! C3640 설정 (다이나밉스)

conf t

 interface range f0/9 -14

 switchport trunk encapsulation dot1q

switchport mode trunk

SW4

! 여기서는 SW4를 사용하지 않는다.

! C3550 설정

conf t

 interface range f0/19 -24

shutdown

 

! C3640 설정 (다이나밉스)

conf t

 interface range f0/9 -14

 shutdown

 

 

 

ⓑ 스위치간 VTP 설정

 

[스위치 VTP 설정]

구분

명령어

SW1

! C3550 설정

conf t

vtp domain VTP_01

vtp mode server

end             

 

! C3640 설정 (다이나밉스)

vlan database

 vtp domain VTP_01

 vtp server

exit

SW2

! C3550 설정

conf t

vtp mode client

end             

 

! C3640 설정 (다이나밉스)

vlan database

vtp client

exit

SW3

! C3550 설정

conf t

vtp mode client

end             

 

! C3640 설정 (다이나밉스)

vlan database

vtp client

exit

 

 

 

ⓒ 스위치간 VLAN 설정

 

끝으로 VLAN을 설정하고 각 스위치별로 L2 인터페이스를 VLAN들에 할당하도록 한다.

 

[스위치 VTP 설정]

구분

명령어

SW1

! C3550 설정

conf t

vlan 11

 name VLAN_BB1

vlan 12

 name VLAN_BB2

vlan 13

 name VLAN_BB3

end             

 

! C3640 설정 (다이나밉스)

vlan database

vlan 11 name VLAN_BB1

vlan 12 name VLAN_BB2

vlan 13 name VLAN_BB3

exit

 

! L2 인터페이스를 VLAN에 할당

interface f0/10

 switchport mode access

switchport access vlan 11

!

interface f0/1

 switchport mode access

switchport access vlan 11

!

interface f0/2

 switchport mode access

switchport access vlan 12

!

interface f0/3

 switchport mode access

switchport access vlan 13

SW2

! VLAN 설정없음

!

! L2 인터페이스를 VLAN에 할당

interface f0/10

 switchport mode access

switchport access vlan 12

SW3

! VLAN 설정없음

!

! L2 인터페이스를 VLAN에 할당

interface f0/10

 switchport mode access

switchport access vlan 13

 

 

 

③ 라우팅 프로토콜 설정

 

라우터간의 라우팅을 먼저 설정해 본다. R1 R2 FR 구간을 OSPF AREA 0로 설정하고 네트웍 타입은 P2P로 설정하도록 한다. R2 R3 FR 구간에는 EIGRP YY가 동작중이다.

 

이번에는 라우터와 백본간의 설정을 해보도록 하자. R1 RIP을 통해 BB1과 연동되어 있고 R3 EIGRP 100을 통해 BB3과 연동되어 있다. R2 AS 번호는 YY이며, AS번호 254를 이용하는 BB2 BGP로 연동되어 있다. 그리고 loopback 0 YY.YY.X.X/32로 설정하고 R1R2 OSPF, R3 EIGRP YY에서 각각 광고하도록 한다.

 

[라우팅 프로토콜 설정]

구분

명령어

R1

router ospf 1

 router-id 1.1.1.1

 log-adjacency-changes

 network 1.1.1.1 0.0.0.0 area 0

 network 1.1.12.1 0.0.0.0 area 0

!

router rip

 version 2

 passive-interface default

 no passive-interface fastethernet 0/0

 network 150.1.0.0

 no auto-summary

R2

router eigrp 1

 network 1.1.23.2 0.0.0.0

 no auto-summary

!

router ospf 1

 router-id 1.1.2.2

 log-adjacency-changes

 network 1.1.2.2 0.0.0.0 area 0

 network 1.1.12.2 0.0.0.0 area 0

!

router bgp 1

 no synchronization

 bgp router-id 1.1.2.2

 bgp log-neighbor-changes

 neighbor 150.2.1.254 remote-as 254

 no auto-summary

R3

router eigrp 1

 network 1.1.3.3 0.0.0.0

 network 1.1.23.3 0.0.0.0

 no auto-summary

!

router eigrp 100

 network 150.3.1.1 0.0.0.0

 no auto-summary

 

 

 

④ 라우팅 테이블 확인

 

여기까지 설정했으면 최종적으로 라우팅 프로토콜별로 라우팅 테이블을 확인을 하도록 한다.

 

[최종 라우팅 확인]

구분

명령어

R1

! RIP 라우팅 테이블

R1#show ip route rip

R    199.172.11.0/24 [120/1] via 150.1.1.254, <?xml:namespace prefix = st1 /><?xml:namespace prefix = st1 />00:00:20, FastEthernet0/0

(생략)

 

! OSPF 라우팅 테이블

R1#show ip route ospf

     1.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

O       1.1.2.2/32 [110/65] via 1.1.12.2, 00:00:28, Serial1/0

R2

! EIGRP 1 라우팅 테이블

R2#show ip route eigrp 1

     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

D       1.1.3.3/32 [90/2297856] via 1.1.23.3, 00:00:08, Serial1/1

 

! OSPF 라우팅 테이블

R2#show ip route ospf

     1.0.0.0/8 is variably subnetted, 5 subnets, 2 masks

O       1.1.1.1/32 [110/65] via 1.1.12.1, 00:01:19, Serial1/0

 

! BGP 라우팅 테이블

R2#show ip route bgp

B    197.68.1.0/24 [20/0] via 150.2.1.254, 00:08:43

B    197.68.5.0/24 [20/0] via 150.2.1.254, 00:08:43

B    197.68.21.0/24 [20/0] via 150.2.1.254, 00:08:43

B    197.68.4.0/24 [20/0] via 150.2.1.254, 00:08:43

B    197.68.22.0/24 [20/0] via 150.2.1.254, 00:08:43

R3

! EIGRP 1 라우팅 테이블

R3#show ip route eigrp 1

(없음)

 

! EIGRP 100 라우팅 테이블

R3#show ip route eigrp 100

     4.0.0.0/24 is subnetted, 1 subnets

D EX    4.1.1.0 [170/156160] via 150.3.1.254, 00:15:01, FastEthernet0/0

(생략)

 

 

 

여기까지 정상적으로 확인이 되었다면, 다음장부터는 동일한 라우팅 프로토콜내에서 또는 상이한 라우팅 프로토콜간에 라우팅 테이블을 업데이트하고 이에 대한 필터링을 하도록 한다.

 

 

 

[copy right by CrazyWoo(우명하); woomha@naver.com]


Title
List of Articles
번호 제목 글쓴이 날짜 조회 수
공지 How To Install GNS3 on Ubuntu 10.04 LTS Hojung 2011.04.25 6160
50 Cisco SPAN Hojung 2013.04.17 2134
49 f/r setting on main interface Hojung 2011.05.03 2239
48 Reset configuration in router/switch Hojung 2011.05.03 2552
47 Basic Configuration (password, domain-lookup, hostname, timeout) Hojung 2011.05.03 3023
46 [Crazy4CCIE-R&S편]VII.Security Hojung 2011.04.27 5026
45 [Crazy4CCIE-R&S편]VI. IP QoS (완료) Hojung 2011.04.27 9015
44 [Crazy4CCIE-R&S편]V.IP Multicast (완료) Hojung 2011.04.27 8630
43 [Crazy4CCIE R&S편]번외편 - 다이나밉스 운영 환경 최적화 Hojung 2011.04.27 5018
42 [Crazy4CCIE-R&S편]IV.IP and IOS Feature (완료) Hojung 2011.04.27 6256
41 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(3)-OSPFv3) Hojung 2011.04.27 4766
40 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(2)-RIPng) Hojung 2011.04.27 3452
39 [Crazy4CCIE-R&S편]II.IGP(9-IPv6-(1)-Concept) Hojung 2011.04.27 3276
38 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(3)-Red&Filter) Hojung 2011.04.27 2845
37 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(2)-Red&Metric) Hojung 2011.04.27 4960
36 [Crazy4CCIE-R&S편]II.IGP(8-Redistribute(재분배)-(1)-Concept) Hojung 2011.04.27 6929
35 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(3)-distribute-list-설정) Hojung 2011.04.27 3699
» [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(2)-labconfig) Hojung 2011.04.27 2556
33 [Crazy4CCIE-R&S편]II.IGP(7-Distribute-(1)-concept Hojung 2011.04.27 2423
32 [Crazy4CCIE-R&S편]II.IGP(6-Filtering-(1~5)access-list&prefix-list Hojung 2011.04.27 3945
31 [Crazy4CCIE-R&S편]II.IGP(5-EIGRP-(5)-Authentication) Hojung 2011.04.27 2820
Board Pagination ‹ Prev 1 2 3 Next ›
/ 3

Designed by sketchbooks.co.kr / sketchbook5 board skin

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5

Sketchbook5, 스케치북5